[GiNaC-list] Building of GINAC fails at compiling GINSH and linking of CLN

Vladimir V. Kisil kisilv at maths.leeds.ac.uk
Thu Sep 20 10:57:34 CEST 2018

>>>>> On Thu, 20 Sep 2018 00:07:09 +0200, Oleg Kmechak <ofcrashbash at gmail.com> said:

    OK> Hello, I am student on Physics Faculty at University of Warsaw
    OK> and new to GINAC.  Currently just trying to build it from git
    OK> repository.

    OK> first case: I installed and build up CLN(to default /usr/local
    OK> dir), then I tried to build GINAC.  second case: I installed cln
    OK> from running command sudo apt install libcln-dev and once again
    OK> tried to build GINAC.  Next everything was as described in
    OK> INSTALL file from GINAC folder: autoreconf -iv ./configure make
    OK> -j 4

    Did you uninstall compiled version of CLN before the official
  package installation? 

    OK> and at some moment it returned: /usr/include/cln/object.h:212:
    OK> undefined reference to `cln::cl_free_heap_object(cln::cl_heap*)'

    OK> collect2: error: ld returned 1 exit status

    What happens if you manually add

LDFLAGS = -L/path/to/CLN-lib

  to GiNaC Makefile?
Vladimir V. Kisil                 http://www.maths.leeds.ac.uk/~kisilv/
  Book:     Geometry of Mobius Transformations     http://goo.gl/EaG2Vu
  Software: Geometry of cycles          http://moebinv.sourceforge.net/

More information about the GiNaC-list mailing list