[GiNaC-list] Building of GINAC fails at compiling GINSH and linking of CLN

Oleg Kmechak ofcrashbash at gmail.com
Thu Sep 20 00:07:09 CEST 2018


I am student on Physics Faculty at University of Warsaw and new to GINAC.
Currently just trying to build it from git repository.

first case: I installed and build up CLN(to default /usr/local dir), then I
tried to build GINAC.
second case: I installed cln from running command sudo apt install
libcln-dev and once again tried to build GINAC.
Next everything was as described in INSTALL file from GINAC folder:
autoreconf -iv
make -j 4

and at some moment it returned:
/usr/include/cln/object.h:212: undefined reference to

collect2: error: ld returned 1 exit status

Makefile:474: recipe for target 'ginsh' failed

make[2]: *** [ginsh] Error 1

Also please see full log attached below
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.cebix.net/pipermail/ginac-list/attachments/20180920/2f6c3aac/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: GINAC log.zip
Type: application/x-zip-compressed
Size: 8931 bytes
Desc: not available
URL: <http://www.cebix.net/pipermail/ginac-list/attachments/20180920/2f6c3aac/attachment.bin>

More information about the GiNaC-list mailing list