ROOT 3.02/06 and GiNaC 1.0.3

Richard B. Kreckel kreckel at
Sat Jan 5 22:35:38 CET 2002


On Fri, 4 Jan 2002, Hans Peter Würmli wrote:
> I tried to interprete the simple GiNaC example (from the
> Tutorial) with cint and root/cint, but the interpreter complains that
> library_init() is declared, but not defined. It is defined in
> utils.cpp. I tried to "gSystem->Load("");" in root, but if I'
> lucky, the new cint error message in root is "~library_init() declared,
> but not defined" (~library_init() does in fact no seem to be defined).

Err?  It's declared in ex.h and defined right below the definition of the
ctor in utils.cpp.  How could you not find it?  Hmm, its definition is a
little bit trivial, but still a text symbol in your library should have
been generated.  So it seems to be just another stupid bug in Cint.

Guess what?  This is a constant source of trouble: Cint wants to link
against every function/method that has ever been declared.  So, although
library_init's ctors and dtors are absolutely none of Cint's business, it
still needs a text symbol in the library.  But anyways, as I said, it
should be there.  nm(1) is your friend in such cases.

> Could anybody give me a hint, what I should do?

Please try to download the ginaccint sources from the usual FTP-site,
install a vanilla Cint (without Root) and see how that works.  I was
reasonably successful with Cint version 5.15.24.  If this enlightens you,
then proceed with Root.

Good luck
Richard B. Kreckel
<Richard.Kreckel at Uni-Mainz.DE>

More information about the GiNaC-list mailing list