[GiNaC-list] cannot compile cpp code that uses GiNaC on Mac OS 10.15.7 (Catalina)

Di Gi dgo.gaz at gmail.com
Sun Dec 20 15:12:11 CET 2020


I'm trying to compile cpp code that depends on GiNaC. The code is in this file:


and I tried compiling it with the following command:

g++ -std=c++11 GPLs.cpp -o GPLs.out -w -lcln -lginac

I tried several alternatives for the -std option, but c++11 is the one producing the smallest amount of errors.

The output I get is in the attached GPLs.log file.

My OS is Mac OS Catalina (10.15.7). My compiler options are as follows:

Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/c++/4.2.1
Apple clang version 12.0.0 (clang-1200.0.32.21)
Target: x86_64-apple-darwin19.6.0
Thread model: posix
InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

I get the very same errors if I use the GNU compiler, but I understand that, under Mac, g++ = gcc = clang.

I installed GiNaC through homebrew, and this is the version I have:

ginac: stable 1.8.0 (bottled)
Not a Computer algebra system
/usr/local/Cellar/ginac/1.8.0 (66 files, 8.9MB) *
  Poured from bottle on 2020-12-19 at 16:28:49
From: https://github.com/Homebrew/homebrew-core/blob/HEAD/Formula/ginac.rb
License: GPL-2.0
==> Dependencies
Build: pkg-config ✔
Required: cln ✔, python at 3.9 ✔, readline ✔

I had also tried to install GiNaC as well as CLN from git, but I get similar errors.

I inspected GiNaC's lst header (the constructor producing the errors) but I cannot find anything wrong with it.

Any help is greatly appreciated.

Beste Grüße,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: GPLs.log
Type: application/octet-stream
Size: 14717 bytes
Desc: not available
URL: <http://www.ginac.de/pipermail/ginac-list/attachments/20201220/828cb593/attachment.obj>

More information about the GiNaC-list mailing list