[GiNaC-list] Evaluating multiple polylogarithms using GiNaC

Peter Banks exodus6395 at gmail.com
Wed Aug 10 23:38:18 CEST 2016

Hi there,

I am having a bit of trouble evaluating some multiple polylogarithms
using the latest version of GiNaC. GiNaC is giving me a different
response depending on whether I input the values as fractions or

Specifically, I'm trying to find a floating point representation for
Li({1,1,2}, {1+1/2*I, 1, 3/5 - 4/5*I}). I've tried this by running (in

evalf(Li({1,1,2}, {1+1/2*I, 1, 3/5 - 4/5*I}));

but this seems to hang (I've run it for over 12 hours with no result).

On the other hand, running

evalf(Li({1,1,2}, {1+0.5*I, 1, 3/5 - 4/5*I}));

gives an answer almost immediately.

I've tried this using a C++ program (see attached) which behaves in
the same way: no result using the fraction but an answer with no
issues using a decimal number.

These calculations have been run using GiNaC 1.7.0 (stable & from git)
on ArchLinux.

Please let me know if there is anything I should try.


PS: I tried sending this email from a different address but it said it
was greylist - I apologise if I've sent this twice.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ginac.cpp
Type: text/x-c++src
Size: 386 bytes
Desc: not available
URL: <http://www.cebix.net/pipermail/ginac-list/attachments/20160810/07dbb734/attachment.cpp>

More information about the GiNaC-list mailing list