[GiNaC-list] Trouble building example from manual

Ken Smith kgsmith at gmail.com
Tue Nov 27 07:51:05 CET 2007

First my environment.

Mac OS 10.5.1 (Darwin 9.1.0)
gcc version 4.0.1 (Apple Inc. build 5465)

I get a coredump when I run the first example from section 2.1 of the GiNaC
1.4.1 Tutorial, revision 5 September 2007.  Here is the stack trace.

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000002
0x00000002 in ?? ()
(gdb) bt
#0  0x00000002 in ?? ()
#1  0x006d6480 in cl_module__cl_prin_globals__firstglobalfun () at
Cannot access memory at address 0x6

I built my program like this:

g++ -I/usr/local/include -L/usr/local/lib src/tut.cpp -lginac

I also tried adding -lcln -lgmp and -lreadline to the link but the result
was the same.

This same error happens when I attempt to run ginsh.  I was concerned during
the build when configure said:

=== The following minor problems have been detected by configure.
=== Please check the messages below before running "make".
=== (see the section 'Common Problems' in the INSTALL file)

== Unsupported version of libreadline.

== I could not run a test of libreadline (needed for building ginsh).

Configuration of GiNaC 1.4.1 done. Now type "make".

I ignored this and built anyway since I don't plan to use ginsh, just the
library.  Perhaps the issues are unrelated.  Please help me to get started
with building and running the tutorial examples.

   Ken Smith
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.cebix.net/pipermail/ginac-list/attachments/20071127/d4c21e3d/attachment.html

More information about the GiNaC-list mailing list