troubles with ginac 1.2 on debian unstable

Andrius Kurtinaitis andrius.kurtinaitis at
Wed Mar 24 16:12:55 CET 2004

I just tried to link with the shared ginac library instead of static and 
it worked:
g++ -o charpoly charpoly.cpp -L /usr/local/lib -lginac -lcln
Is it some fundamental linux thing that i still do not know?

Andrius Kurtinaitis wrote:
> Hello,
> i was so happy about 1.2 release, that I downloaded the new 1.2 version 
> of ginac, compiled and installed on my debian unstable machine, using 
> usual configure, make, su, make install. I also have another ginac 
> version 1.1.6-1 installed.
> When I build a simple proggy using ginac, I use new (1.2) ginac lib and 
> the old cln:
> g++ -o charpoly charpoly.cpp /usr/local/lib/libginac.a -lcln
> The resulting program crashes with the segmentation fault. Even if it 
> does nothing. Including <ginac/ginac.h> and compiling the empty program 
> is enough to produce the segfault.
> The current installation contains the cln version 1.1.6-1.
> Any hints?
> I thought, it is because of version incompatibility between the cln 
> library and the new ginac. Then i tried to download the newest cln, 
> which, according to its site should be 1.1.7. But the download site 
> does not contain this version...
> Or is it because of different compiler versions used to compile cln and 
> my own ginac 1.2?
> Any ideas?
> Andrius Kurtinaitis

More information about the GiNaC-list mailing list