'make check' fails!

William Woods will_woods2 at yahoo.co.uk
Wed Jul 17 15:45:06 CEST 2002

Ok, I tried some different variations:

CXXFLAGS="-finline-limit=1000" ./configure
--disable-shared --prefix=/usr/local2

passed all tests, but changing to --disable-static
failed all tests.


CXXFLAGS="-O -finline-limit=1000" ./configure
--disable-shared --prefix=/usr/local2

failed only on one single test:

timing Lewis-Wester test M1 (26x26 sparse, det).
failed 0.095s


CXXFLAGS="-DDO_GINAC_ASSERT -O -finline-limit=1000"
./configure --disable-shared --prefix=/usr/local2

passed all tests.

(The gcc3.1 compiler was not standard with this
system, I bootstrapped it)

Any ideas?


 --- "Richard B. Kreckel"
<kreckel at thep.physik.uni-mainz.de> wrote: > On Tue, 16
Jul 2002, William Woods wrote:
> >  The problem seems to be solved by specifying:
> > 
> > -finline-limit=1000" ./configure --disable-shared
> > --prefix=/usr/local2
> Could you please try changing some of these flags to
> reasonable defaults
> such that we find out which of the original setings
> (presumably "-g
> -O2") causes the probem?  Or, leave the CXXFLAGS and
> configure specifying
> --disable-static because without any of
> --disable-{shared,static} you were
> most probably linking against the shared library and
> EH there is more
> tricky.
> So, my guesses are: 1) shared library exception
> handling is broken on your
> system, 2) -O2 miscomples some code.  In that order.
>  The other flags are
> most probably irrelevant.
> Where did you get the compiler from?  Did you
> bootstrap it or did it come
> with the system?
> Regards
>      -richy.
> -- 
> Richard B. Kreckel
> <Richard.Kreckel at Uni-Mainz.DE>
> <http://wwwthep.physik.uni-mainz.de/~kreckel/>

Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts

More information about the GiNaC-list mailing list