- Patches needed for cygwin.