update the compiler info; tell users to avoid GCC 4.3.0