]> www.ginac.de Git - ginac.git/blobdiff - ginsh/Makefile.am
* numeric::print(): increase precision for C source output.
[ginac.git] / ginsh / Makefile.am
index bf407e24d2f349ffde8093b56e6a69da74a574b3..d72090656453394373c9037c9f8fce349db91d50 100644 (file)
@@ -1,21 +1,22 @@
 ## Process this file with automake to produce Makefile.in
 
 bin_PROGRAMS = ginsh
 ## Process this file with automake to produce Makefile.in
 
 bin_PROGRAMS = ginsh
-ginsh_SOURCES = ginsh_parser.yy ginsh_lexer.ll ginsh.h
+ginsh_SOURCES = ginsh_parser.yy ginsh_lexer.ll ginsh.h ginsh_extensions.h
 ginsh_LDADD = ../ginac/libginac.la $(GINSH_LIBS)
 
 ginsh_LDADD = ../ginac/libginac.la $(GINSH_LIBS)
 
-INCLUDES = -I$(srcdir)/../ginac -DIN_GINAC
+INCLUDES = -I$(srcdir)/../ginac -I../ginac -DIN_GINAC
 YFLAGS = -d
 
 man_MANS = ginsh.1
 
 YFLAGS = -d
 
 man_MANS = ginsh.1
 
+CLEANFILES = ginsh_fcn_help.h ginsh_op_help.h
 EXTRA_DIST = ginsh_parser.h ginsh_fcn_help.sed ginsh_op_help.sed
 
 # files created by sed scripts
 EXTRA_DIST = ginsh_parser.h ginsh_fcn_help.sed ginsh_op_help.sed
 
 # files created by sed scripts
-ginsh_fcn_help.c: ginsh.1 $(srcdir)/ginsh_fcn_help.sed
+ginsh_fcn_help.h: ginsh.1 $(srcdir)/ginsh_fcn_help.sed
        sed -n -f $(srcdir)/ginsh_fcn_help.sed <$< >$@
 
        sed -n -f $(srcdir)/ginsh_fcn_help.sed <$< >$@
 
-ginsh_op_help.c: ginsh.1 $(srcdir)/ginsh_op_help.sed
+ginsh_op_help.h: ginsh.1 $(srcdir)/ginsh_op_help.sed
        sed -n -f $(srcdir)/ginsh_op_help.sed <$< >$@
 
        sed -n -f $(srcdir)/ginsh_op_help.sed <$< >$@
 
-ginsh_parser.o: ginsh_fcn_help.c ginsh_op_help.c
+ginsh_parser.o: ginsh_fcn_help.h ginsh_op_help.h