]> www.ginac.de Git - ginac.git/blobdiff - ginsh/Makefile.am
improved the CLN C-source output (integers are printed as integers, and
[ginac.git] / ginsh / Makefile.am
index 4317977891acf5558ca5cb6e84edf31e6fae5062..d72090656453394373c9037c9f8fce349db91d50 100644 (file)
@@ -9,13 +9,14 @@ YFLAGS = -d
 
 man_MANS = ginsh.1
 
+CLEANFILES = ginsh_fcn_help.h ginsh_op_help.h
 EXTRA_DIST = ginsh_parser.h ginsh_fcn_help.sed ginsh_op_help.sed
 
 # files created by sed scripts
-$(srcdir)/ginsh_fcn_help.c: ginsh.1 $(srcdir)/ginsh_fcn_help.sed
+ginsh_fcn_help.h: ginsh.1 $(srcdir)/ginsh_fcn_help.sed
        sed -n -f $(srcdir)/ginsh_fcn_help.sed <$< >$@
 
-$(srcdir)/ginsh_op_help.c: ginsh.1 $(srcdir)/ginsh_op_help.sed
+ginsh_op_help.h: ginsh.1 $(srcdir)/ginsh_op_help.sed
        sed -n -f $(srcdir)/ginsh_op_help.sed <$< >$@
 
-ginsh_parser.o: $(srcdir)/ginsh_fcn_help.c $(srcdir)/ginsh_op_help.c
+ginsh_parser.o: ginsh_fcn_help.h ginsh_op_help.h