]> www.ginac.de Git - ginac.git/blobdiff - ginsh/Makefile.am
* Fix incompatibilities with recent versions of libreadline by having
[ginac.git] / ginsh / Makefile.am
index 25a5d8e45f823f4de16463ab5ec196f9d0b80e5f..d391d3b03999c851514398a7213342fb32f63e0e 100644 (file)
@@ -1,6 +1,21 @@
 ## Process this file with automake to produce Makefile.in
+
 bin_PROGRAMS = ginsh
 ginsh_SOURCES = ginsh_parser.yy ginsh_lexer.ll ginsh.h
-ginsh_LDADD = @LIBOBJS@ ../ginac/libginac.la
-man_MANS = ginsh.1
+ginsh_LDADD = ../ginac/libginac.la $(GINSH_LIBS)
+
+INCLUDES = -I$(srcdir)/../ginac -I../ginac -DIN_GINAC
 YFLAGS = -d
+
+man_MANS = ginsh.1
+
+EXTRA_DIST = ginsh_parser.h ginsh_fcn_help.sed ginsh_op_help.sed
+
+# files created by sed scripts
+ginsh_fcn_help.c: ginsh.1 $(srcdir)/ginsh_fcn_help.sed
+       sed -n -f $(srcdir)/ginsh_fcn_help.sed <$< >$@
+
+ginsh_op_help.c: ginsh.1 $(srcdir)/ginsh_op_help.sed
+       sed -n -f $(srcdir)/ginsh_op_help.sed <$< >$@
+
+ginsh_parser.o: ginsh_fcn_help.c ginsh_op_help.c