]> www.ginac.de Git - ginac.git/blobdiff - ginsh/Makefile.am
[build] Move library version info into the version.h file.
[ginac.git] / ginsh / Makefile.am
index f252a0297f55e1612391d51d35b2ea392f54235e..c4269f56a4f74c4bdfccae9c1b1242fb6a4c75d5 100644 (file)
@@ -1,7 +1,22 @@
 ## Process this file with automake to produce Makefile.in
+
 bin_PROGRAMS = ginsh
-ginsh_SOURCES = ginsh_parser.yy ginsh_lexer.ll ginsh.h
+ginsh_SOURCES = ginsh_parser.yy ginsh_lexer.ll ginsh.h ginsh_extensions.h
 ginsh_LDADD = ../ginac/libginac.la $(GINSH_LIBS)
+
+INCLUDES = -I$(srcdir)/../ginac -I../ginac -DIN_GINAC
+AM_YFLAGS = -d
+
 man_MANS = ginsh.1
-YFLAGS = -d
-EXTRA_DIST = ginsh_parser.h
+
+CLEANFILES = ginsh_fcn_help.h ginsh_op_help.h
+EXTRA_DIST = ginsh_parser.h ginsh_fcn_help.py ginsh_op_help.py
+
+# files created by sed scripts
+ginsh_fcn_help.h: ginsh.1.in $(srcdir)/ginsh_fcn_help.py
+       $(PYTHON) $(srcdir)/ginsh_fcn_help.py -o $@ $<
+
+ginsh_op_help.h: ginsh.1 $(srcdir)/ginsh_op_help.py
+       $(PYTHON) $(srcdir)/ginsh_op_help.py -o $@ $<
+
+ginsh_parser.o: ginsh_fcn_help.h ginsh_op_help.h ginsh_parser.h