]> www.ginac.de Git - ginac.git/blobdiff - ginsh/Makefile.am
- ginsh_fcn_help/ginsh_op_help.c are renamed to *.h and now placed in the
[ginac.git] / ginsh / Makefile.am
index bf407e24d2f349ffde8093b56e6a69da74a574b3..99fa0b241a1fc320d1bc8958fc6178fdd6273b06 100644 (file)
@@ -1,10 +1,10 @@
 ## Process this file with automake to produce Makefile.in
 
 bin_PROGRAMS = ginsh
-ginsh_SOURCES = ginsh_parser.yy ginsh_lexer.ll ginsh.h
+ginsh_SOURCES = ginsh_parser.yy ginsh_lexer.ll ginsh.h ginsh_extensions.h
 ginsh_LDADD = ../ginac/libginac.la $(GINSH_LIBS)
 
-INCLUDES = -I$(srcdir)/../ginac -DIN_GINAC
+INCLUDES = -I$(srcdir)/../ginac -I../ginac -DIN_GINAC
 YFLAGS = -d
 
 man_MANS = ginsh.1
@@ -12,10 +12,10 @@ man_MANS = ginsh.1
 EXTRA_DIST = ginsh_parser.h ginsh_fcn_help.sed ginsh_op_help.sed
 
 # files created by sed scripts
-ginsh_fcn_help.c: ginsh.1 $(srcdir)/ginsh_fcn_help.sed
+ginsh_fcn_help.h: ginsh.1 $(srcdir)/ginsh_fcn_help.sed
        sed -n -f $(srcdir)/ginsh_fcn_help.sed <$< >$@
 
-ginsh_op_help.c: ginsh.1 $(srcdir)/ginsh_op_help.sed
+ginsh_op_help.h: ginsh.1 $(srcdir)/ginsh_op_help.sed
        sed -n -f $(srcdir)/ginsh_op_help.sed <$< >$@
 
-ginsh_parser.o: ginsh_fcn_help.c ginsh_op_help.c
+ginsh_parser.o: ginsh_fcn_help.h ginsh_op_help.h