]> www.ginac.de Git - ginac.git/blobdiff - ginsh/Makefile.am
Fix build from git repository.
[ginac.git] / ginsh / Makefile.am
index cc02f92d32277ab8739574ee56c8eceba77a758b..2de56d45acf1dfdf758c8a5d1ff41ceec20a9d11 100644 (file)
@@ -1,7 +1,23 @@
 ## Process this file with automake to produce Makefile.in
+
 bin_PROGRAMS = ginsh
-ginsh_SOURCES = ginsh_parser.yy ginsh_lexer.ll ginsh.h
-ginsh_LDADD = @LIBOBJS@ ../ginac/libginac.la
+BUILT_SOURCES = ginsh_parser.cpp ginsh_lexer.cpp
+ginsh_SOURCES = ginsh_parser.ypp ginsh_lexer.lpp ginsh.h ginsh_extensions.h
+ginsh_LDADD = ../ginac/libginac.la $(GINSH_LIBS)
+
+AM_CPPFLAGS = -I$(srcdir)/../ginac -I../ginac -DIN_GINAC
+AM_YFLAGS = -d
+
 man_MANS = ginsh.1
-YFLAGS = -d
-EXTRA_DIST = ginsh_parser.h
+
+CLEANFILES = ginsh_fcn_help.h ginsh_op_help.h
+EXTRA_DIST = ginsh_fcn_help.py ginsh_op_help.py
+
+# files created by sed scripts
+ginsh_fcn_help.h: ginsh.1.in $(srcdir)/ginsh_fcn_help.py
+       $(PYTHON) $(srcdir)/ginsh_fcn_help.py -o $@ $<
+
+ginsh_op_help.h: ginsh.1 $(srcdir)/ginsh_op_help.py
+       $(PYTHON) $(srcdir)/ginsh_op_help.py -o $@ $<
+
+ginsh_parser.o: ginsh_fcn_help.h ginsh_op_help.h ginsh_parser.cpp