]> www.ginac.de Git - ginac.git/blobdiff - ginsh/Makefile.am
- removed an obscure reference that broke internal functions.
[ginac.git] / ginsh / Makefile.am
index cc02f92d32277ab8739574ee56c8eceba77a758b..0cdab1d5c1f0b81d3e8021245a4a10a8f2ab0fa8 100644 (file)
@@ -1,7 +1,17 @@
 ## Process this file with automake to produce Makefile.in
+
 bin_PROGRAMS = ginsh
 ginsh_SOURCES = ginsh_parser.yy ginsh_lexer.ll ginsh.h
-ginsh_LDADD = @LIBOBJS@ ../ginac/libginac.la
+ginsh_LDADD = ../ginac/libginac.la $(GINSH_LIBS)
 man_MANS = ginsh.1
 YFLAGS = -d
 EXTRA_DIST = ginsh_parser.h
+
+# files created by sed scripts
+ginsh_fcn_help.c: ginsh.1 ginsh_fcn_help.sed
+       sed -n -f ginsh_fcn_help.sed <$< >$@
+
+ginsh_op_help.c: ginsh.1 ginsh_op_help.sed
+       sed -n -f ginsh_op_help.sed <$< >$@
+
+ginsh_parser.cc: ginsh_fcn_help.c ginsh_op_help.c