]> www.ginac.de Git - ginac.git/blobdiff - ginsh/Makefile.am
[build] Rewrite ginsh related sed scripts in python.
[ginac.git] / ginsh / Makefile.am
index 6789fc4429e22898e52b91fee95551418668484d..c4269f56a4f74c4bdfccae9c1b1242fb6a4c75d5 100644 (file)
@@ -10,13 +10,13 @@ AM_YFLAGS = -d
 man_MANS = ginsh.1
 
 CLEANFILES = ginsh_fcn_help.h ginsh_op_help.h
-EXTRA_DIST = ginsh_parser.h ginsh_fcn_help.sed ginsh_op_help.sed
+EXTRA_DIST = ginsh_parser.h ginsh_fcn_help.py ginsh_op_help.py
 
 # files created by sed scripts
-ginsh_fcn_help.h: ginsh.1 $(srcdir)/ginsh_fcn_help.sed
-       sed -n -f $(srcdir)/ginsh_fcn_help.sed <$< >$@
+ginsh_fcn_help.h: ginsh.1.in $(srcdir)/ginsh_fcn_help.py
+       $(PYTHON) $(srcdir)/ginsh_fcn_help.py -o $@ $<
 
-ginsh_op_help.h: ginsh.1 $(srcdir)/ginsh_op_help.sed
-       sed -n -f $(srcdir)/ginsh_op_help.sed <$< >$@
+ginsh_op_help.h: ginsh.1 $(srcdir)/ginsh_op_help.py
+       $(PYTHON) $(srcdir)/ginsh_op_help.py -o $@ $<
 
 ginsh_parser.o: ginsh_fcn_help.h ginsh_op_help.h ginsh_parser.h