]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
- prepared for 1.0.13 release
[ginac.git] / ginac / Makefile.am
index d0b9db47d27ce9bf5f6ef76d3663370299bd0e32..f0896bd4d802447fd52bfc63ca53000829c75eef 100644 (file)
@@ -2,26 +2,25 @@
 
 lib_LTLIBRARIES = libginac.la
 libginac_la_SOURCES = add.cpp archive.cpp basic.cpp constant.cpp ex.cpp \
-  expairseq.cpp exprseq.cpp fail.cpp function.cpp inifcns.cpp \
+  expair.cpp expairseq.cpp exprseq.cpp fail.cpp function.cpp inifcns.cpp \
   inifcns_trans.cpp inifcns_zeta.cpp inifcns_gamma.cpp matrix.cpp mul.cpp \
   normal.cpp numeric.cpp operators.cpp power.cpp registrar.cpp relational.cpp \
-  symbol.cpp pseries.cpp utils.cpp ncmul.cpp clifford.cpp structure.cpp \
-  color.cpp indexed.cpp idx.cpp isospin.cpp exprseq_suppl.cpp lst.cpp \
-  lst_suppl.cpp simp_lor.cpp coloridx.cpp lorentzidx.cpp lortensor.cpp \
-  input_parser.yy input_lexer.ll input_lexer.h \
-  remember.h remember.cpp debugmsg.h utils.h 
+  symbol.cpp pseries.cpp utils.cpp ncmul.cpp structure.cpp exprseq_suppl.cpp \
+  lst.cpp lst_suppl.cpp input_parser.yy input_lexer.ll input_lexer.h \
+  remember.h remember.cpp utils.h idx.cpp indexed.cpp tensor.cpp color.cpp \
+  clifford.cpp wildcard.cpp print.cpp symmetry.cpp fderivative.cpp tostring.h
 libginac_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
   -release $(LT_RELEASE)
 ginacincludedir = $(includedir)/ginac
-ginacinclude_HEADERS = ginac.h add.h archive.h basic.h clifford.h color.h \
-  coloridx.h constant.h ex.h expair.h expairseq.h exprseq.h fail.h flags.h \
-  function.h idx.h indexed.h inifcns.h isospin.h lorentzidx.h lst.h matrix.h \
-  mul.h ncmul.h normal.h numeric.h operators.h power.h registrar.h \
-  relational.h pseries.h simp_lor.h structure.h symbol.h lortensor.h tinfos.h \
-  assertion.h
+ginacinclude_HEADERS = ginac.h add.h archive.h basic.h constant.h ex.h \
+  expair.h expairseq.h exprseq.h fail.h flags.h function.h inifcns.h \
+  lst.h matrix.h mul.h ncmul.h normal.h numeric.h operators.h power.h \
+  registrar.h relational.h pseries.h structure.h symbol.h tinfos.h assertion.h \
+  version.h idx.h indexed.h tensor.h color.h clifford.h wildcard.h print.h \
+  symmetry.h fderivative.h
 LFLAGS = -Pginac_yy -olex.yy.c
 YFLAGS = -p ginac_yy -d
-EXTRA_DIST = container.pl function.pl structure.pl input_parser.h
+EXTRA_DIST = container.pl function.pl structure.pl input_parser.h version.h.in
 
 # Files which are generated by perl scripts
 $(srcdir)/function.h $(srcdir)/function.cpp: $(srcdir)/function.pl