]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
- diff() is now only defined on classes ex and basic, where it handles
[ginac.git] / ginac / Makefile.am
index 1035e836d984e493da597bb96518f0669b34ec98..e0cf87d53caec59e8d3575d2fb430882197c985b 100644 (file)
@@ -1,8 +1,8 @@
 ## Process this file with automake to produce Makefile.in
 
 lib_LTLIBRARIES = libginac.la
-libginac_la_SOURCES = add.cpp archive.cpp basic.cpp constant.cpp diff.cpp \
-  ex.cpp expairseq.cpp exprseq.cpp fail.cpp function.cpp inifcns.cpp \
+libginac_la_SOURCES = add.cpp archive.cpp basic.cpp constant.cpp ex.cpp \
+  expairseq.cpp exprseq.cpp fail.cpp function.cpp inifcns.cpp \
   inifcns_trans.cpp inifcns_zeta.cpp inifcns_gamma.cpp matrix.cpp mul.cpp \
   normal.cpp numeric.cpp operators.cpp power.cpp registrar.cpp relational.cpp \
   symbol.cpp pseries.cpp utils.cpp ncmul.cpp clifford.cpp structure.cpp \
@@ -21,14 +21,14 @@ ginacinclude_HEADERS = ginac.h add.h archive.h basic.h clifford.h color.h \
 EXTRA_DIST = container.pl function.pl structure.pl
 
 # Files which are generated by perl scripts
-function.h function.cpp: function.pl
-       perl function.pl
+$(srcdir)/function.h $(srcdir)/function.cpp: $(srcdir)/function.pl
+       cd $(srcdir) && perl function.pl
 
-lst.h lst.cpp: container.pl
-       perl container.pl lst
+$(srcdir)/lst.h $(srcdir)/lst.cpp: $(srcdir)/container.pl
+       cd $(srcdir) && perl container.pl lst
 
-exprseq.h exprseq.cpp: container.pl
-       perl container.pl exprseq
+$(srcdir)/exprseq.h $(srcdir)/exprseq.cpp: $(srcdir)/container.pl
+       cd $(srcdir) && perl container.pl exprseq
 
 # Force build of headers before compilation
-add.cpp: function.h lst.h exprseq.h
+$(srcdir)/add.cpp: $(srcdir)/function.h $(srcdir)/lst.h $(srcdir)/exprseq.h