]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
- rotate_31() and golden_hash_ratio() moved to utils.h
[ginac.git] / ginac / Makefile.am
index 9d8ed38eb45f3523eb563aed5f88dad6afcc0c2e..d2f9570ba9c47d7fad0655293f17e79b6a763de3 100644 (file)
@@ -1,13 +1,14 @@
 ## Process this file with automake to produce Makefile.in
+
 lib_LTLIBRARIES = libginac.la
 libginac_la_SOURCES = add.cpp basic.cpp constant.cpp diff.cpp ex.cpp \
   expairseq.cpp exprseq.cpp fail.cpp function.cpp inifcns.cpp \
-  inifcns_trans.cpp inifcns_gamma.cpp matrix.cpp mul.cpp normal.cpp \
-  numeric.cpp operators.cpp power.cpp print.cpp printraw.cpp printtree.cpp \
-  printcsrc.cpp relational.cpp symbol.cpp utils.cpp series.cpp ncmul.cpp \
-  clifford.cpp structure.cpp color.cpp indexed.cpp idx.cpp isospin.cpp \
-  exprseq_suppl.cpp lst.cpp lst_suppl.cpp simp_lor.cpp coloridx.cpp \
-  lorentzidx.cpp debugmsg.h utils.h
+  inifcns_trans.cpp inifcns_zeta.cpp inifcns_gamma.cpp matrix.cpp mul.cpp \
+  normal.cpp numeric.cpp operators.cpp power.cpp print.cpp printraw.cpp \
+  printtree.cpp printcsrc.cpp relational.cpp symbol.cpp utils.cpp series.cpp \
+  ncmul.cpp clifford.cpp structure.cpp color.cpp indexed.cpp idx.cpp \
+  isospin.cpp exprseq_suppl.cpp lst.cpp lst_suppl.cpp simp_lor.cpp \
+  coloridx.cpp lorentzidx.cpp debugmsg.h utils.h
 libginac_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
   -release $(LT_RELEASE)
 ginacincludedir = $(includedir)/ginac
@@ -16,6 +17,7 @@ ginacinclude_HEADERS = ginac.h add.h basic.h clifford.h color.h coloridx.h \
   idx.h indexed.h inifcns.h isospin.h lorentzidx.h lst.h matrix.h mul.h \
   ncmul.h normal.h numeric.h operators.h power.h relational.h series.h \
   simp_lor.h structure.h symbol.h tinfos.h assertion.h
+EXTRA_DIST = container.pl function.pl structure.pl
 
 # Files which are generated by perl scripts
 function.h function.cpp: function.pl