]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
- expressions can now be read from streams; the input expression can contain
[ginac.git] / ginac / Makefile.am
index c17aea204d633aebcf6ab085d26c96e451e0c582..cbf8f4e73b8703dda2f7e807c0a91f509ce44e6a 100644 (file)
@@ -8,6 +8,7 @@ libginac_la_SOURCES = add.cpp archive.cpp basic.cpp constant.cpp ex.cpp \
   symbol.cpp pseries.cpp utils.cpp ncmul.cpp clifford.cpp structure.cpp \
   color.cpp indexed.cpp idx.cpp isospin.cpp exprseq_suppl.cpp lst.cpp \
   lst_suppl.cpp simp_lor.cpp coloridx.cpp lorentzidx.cpp lortensor.cpp \
+  input_parser.yy input_lexer.ll input_lexer.h \
   remember.h remember.cpp debugmsg.h utils.h 
 libginac_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
   -release $(LT_RELEASE)
@@ -18,7 +19,9 @@ ginacinclude_HEADERS = ginac.h add.h archive.h basic.h clifford.h color.h \
   mul.h ncmul.h normal.h numeric.h operators.h power.h registrar.h \
   relational.h pseries.h simp_lor.h structure.h symbol.h lortensor.h tinfos.h \
   assertion.h
-EXTRA_DIST = container.pl function.pl structure.pl
+LFLAGS = -olex.yy.c
+YFLAGS = -d
+EXTRA_DIST = container.pl function.pl structure.pl input_parser.h
 
 # Files which are generated by perl scripts
 $(srcdir)/function.h $(srcdir)/function.cpp: $(srcdir)/function.pl