]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
* s/LFLAGS/AM_LFLAGS/, s/YFLAGS/AM_YFLAGS/.
[ginac.git] / ginac / Makefile.am
index 2b961fc1ff755fa8c8a74bcb498ed82060bb5277..c7285c9dcbfc979f14e35f3b0bea650b507b1819 100644 (file)
@@ -4,23 +4,23 @@ lib_LTLIBRARIES = libginac.la
 libginac_la_SOURCES = add.cpp archive.cpp basic.cpp clifford.cpp color.cpp \
   constant.cpp ex.cpp expair.cpp expairseq.cpp exprseq.cpp fail.cpp \
   fderivative.cpp function.cpp idx.cpp indexed.cpp inifcns.cpp \
-  inifcns_trans.cpp inifcns_zeta.cpp inifcns_gamma.cpp lst.cpp matrix.cpp \
-  mul.cpp ncmul.cpp normal.cpp numeric.cpp operators.cpp power.cpp \
-  registrar.cpp relational.cpp remember.cpp pseries.cpp print.cpp structure.cpp \
-  symbol.cpp symmetry.cpp tensor.cpp utils.cpp wildcard.cpp \
+  inifcns_trans.cpp inifcns_gamma.cpp inifcns_nstdsums.cpp \
+  lst.cpp matrix.cpp mul.cpp ncmul.cpp normal.cpp numeric.cpp operators.cpp \
+  power.cpp registrar.cpp relational.cpp remember.cpp pseries.cpp print.cpp \
+  structure.cpp symbol.cpp symmetry.cpp tensor.cpp utils.cpp wildcard.cpp \
   input_parser.yy input_lexer.ll \
   input_lexer.h remember.h tostring.h utils.h
 libginac_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
   -release $(LT_RELEASE)
 ginacincludedir = $(includedir)/ginac
-ginacinclude_HEADERS = ginac.h add.h archive.h assertion.h basic.h clifford.h \
-  color.h constant.h container.h ex.h expair.h expairseq.h exprseq.h fail.h \
-  fderivative.h flags.h function.h idx.h indexed.h inifcns.h lst.h matrix.h \
-  mul.h ncmul.h normal.h numeric.h operators.h power.h print.h pseries.h ptr.h \
-  registrar.h relational.h structure.h symbol.h symmetry.h tensor.h tinfos.h \
-  version.h wildcard.h
-LFLAGS = -Pginac_yy -olex.yy.c
-YFLAGS = -p ginac_yy -d
+ginacinclude_HEADERS = ginac.h add.h archive.h assertion.h basic.h class_info.h \
+  clifford.h color.h constant.h container.h ex.h expair.h expairseq.h exprseq.h \
+  fail.h fderivative.h flags.h function.h hash_map.h idx.h indexed.h inifcns.h \
+  lst.h matrix.h mul.h ncmul.h normal.h numeric.h operators.h power.h print.h \
+  pseries.h ptr.h registrar.h relational.h structure.h symbol.h symmetry.h \
+  tensor.h tinfos.h version.h wildcard.h
+AM_LFLAGS = -Pginac_yy -olex.yy.c
+AM_YFLAGS = -p ginac_yy -d
 EXTRA_DIST = function.pl input_parser.h version.h.in
 
 # Files which are generated by perl scripts