]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
- We now write f(x).series(x==3,5) instead of f(x).series(x,3,5) and
[ginac.git] / ginac / Makefile.am
index 0907823a0a0e6da1d8a5d234d946024a16552cf6..c17aea204d633aebcf6ab085d26c96e451e0c582 100644 (file)
@@ -1,33 +1,34 @@
 ## Process this file with automake to produce Makefile.in
 
 lib_LTLIBRARIES = libginac.la
-libginac_la_SOURCES = add.cpp basic.cpp constant.cpp diff.cpp ex.cpp \
+libginac_la_SOURCES = add.cpp archive.cpp basic.cpp constant.cpp ex.cpp \
   expairseq.cpp exprseq.cpp fail.cpp function.cpp inifcns.cpp \
   inifcns_trans.cpp inifcns_zeta.cpp inifcns_gamma.cpp matrix.cpp mul.cpp \
-  normal.cpp numeric.cpp operators.cpp power.cpp print.cpp printraw.cpp \
-  printtree.cpp printcsrc.cpp relational.cpp symbol.cpp utils.cpp series.cpp \
-  ncmul.cpp clifford.cpp structure.cpp color.cpp indexed.cpp idx.cpp \
-  isospin.cpp exprseq_suppl.cpp lst.cpp lst_suppl.cpp simp_lor.cpp \
-  coloridx.cpp lorentzidx.cpp debugmsg.h utils.h
+  normal.cpp numeric.cpp operators.cpp power.cpp registrar.cpp relational.cpp \
+  symbol.cpp pseries.cpp utils.cpp ncmul.cpp clifford.cpp structure.cpp \
+  color.cpp indexed.cpp idx.cpp isospin.cpp exprseq_suppl.cpp lst.cpp \
+  lst_suppl.cpp simp_lor.cpp coloridx.cpp lorentzidx.cpp lortensor.cpp \
+  remember.h remember.cpp debugmsg.h utils.h 
 libginac_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
   -release $(LT_RELEASE)
 ginacincludedir = $(includedir)/ginac
-ginacinclude_HEADERS = ginac.h add.h basic.h clifford.h color.h coloridx.h \
-  constant.h ex.h expair.h expairseq.h exprseq.h fail.h flags.h function.h \
-  idx.h indexed.h inifcns.h isospin.h lorentzidx.h lst.h matrix.h mul.h \
-  ncmul.h normal.h numeric.h operators.h power.h relational.h series.h \
-  simp_lor.h structure.h symbol.h tinfos.h assertion.h
+ginacinclude_HEADERS = ginac.h add.h archive.h basic.h clifford.h color.h \
+  coloridx.h constant.h ex.h expair.h expairseq.h exprseq.h fail.h flags.h \
+  function.h idx.h indexed.h inifcns.h isospin.h lorentzidx.h lst.h matrix.h \
+  mul.h ncmul.h normal.h numeric.h operators.h power.h registrar.h \
+  relational.h pseries.h simp_lor.h structure.h symbol.h lortensor.h tinfos.h \
+  assertion.h
 EXTRA_DIST = container.pl function.pl structure.pl
 
 # Files which are generated by perl scripts
-function.h function.cpp: function.pl
-       perl function.pl
+$(srcdir)/function.h $(srcdir)/function.cpp: $(srcdir)/function.pl
+       cd $(srcdir) && perl -w function.pl
 
-lst.h lst.cpp: container.pl
-       perl container.pl lst
+$(srcdir)/lst.h $(srcdir)/lst.cpp: $(srcdir)/container.pl
+       cd $(srcdir) && perl -w container.pl lst
 
-exprseq.h exprseq.cpp: container.pl
-       perl container.pl exprseq
+$(srcdir)/exprseq.h $(srcdir)/exprseq.cpp: $(srcdir)/container.pl
+       cd $(srcdir) && perl -w container.pl exprseq
 
 # Force build of headers before compilation
-add.cpp: function.h lst.h exprseq.h
+$(srcdir)/add.cpp: $(srcdir)/function.h $(srcdir)/lst.h $(srcdir)/exprseq.h