]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
- Added version.h.in to EXTRA_DIST.
[ginac.git] / ginac / Makefile.am
index 0c67fd2de5d4d7a5a658d72d0381199696060f05..7a3cd72d6fa573c5d13c6f0044381afb092b0c06 100644 (file)
@@ -8,6 +8,7 @@ libginac_la_SOURCES = add.cpp archive.cpp basic.cpp constant.cpp ex.cpp \
   symbol.cpp pseries.cpp utils.cpp ncmul.cpp clifford.cpp structure.cpp \
   color.cpp indexed.cpp idx.cpp isospin.cpp exprseq_suppl.cpp lst.cpp \
   lst_suppl.cpp simp_lor.cpp coloridx.cpp lorentzidx.cpp lortensor.cpp \
+  input_parser.yy input_lexer.ll input_lexer.h \
   remember.h remember.cpp debugmsg.h utils.h 
 libginac_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
   -release $(LT_RELEASE)
@@ -16,19 +17,21 @@ ginacinclude_HEADERS = ginac.h add.h archive.h basic.h clifford.h color.h \
   coloridx.h constant.h ex.h expair.h expairseq.h exprseq.h fail.h flags.h \
   function.h idx.h indexed.h inifcns.h isospin.h lorentzidx.h lst.h matrix.h \
   mul.h ncmul.h normal.h numeric.h operators.h power.h registrar.h \
-  relational.h pseries.h simp_lor.h structure.h symbol.h lortensor.h tinfos.h \
-  assertion.h
-EXTRA_DIST = container.pl function.pl structure.pl
+  relational.h pseries.h simp_lor.h structure.h symbol.h lortensor.h \
+  tinfos.h assertion.h version.h
+LFLAGS = -Pginac_yy -olex.yy.c
+YFLAGS = -p ginac_yy -d
+EXTRA_DIST = container.pl function.pl structure.pl input_parser.h version.h.in
 
 # Files which are generated by perl scripts
 $(srcdir)/function.h $(srcdir)/function.cpp: $(srcdir)/function.pl
-       cd $(srcdir) && perl function.pl
+       cd $(srcdir) && perl -w function.pl
 
 $(srcdir)/lst.h $(srcdir)/lst.cpp: $(srcdir)/container.pl
-       cd $(srcdir) && perl container.pl lst
+       cd $(srcdir) && perl -w container.pl lst
 
 $(srcdir)/exprseq.h $(srcdir)/exprseq.cpp: $(srcdir)/container.pl
-       cd $(srcdir) && perl container.pl exprseq
+       cd $(srcdir) && perl -w container.pl exprseq
 
 # Force build of headers before compilation
 $(srcdir)/add.cpp: $(srcdir)/function.h $(srcdir)/lst.h $(srcdir)/exprseq.h