]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
some changes to allow GiNaC to cooperate with cint:
[ginac.git] / ginac / Makefile.am
index db760a02e1292ab064c40acfbd3ff1aca1d1696c..4f20370dfb6606aeb1e401fbb0716c9cfdc4a422 100644 (file)
@@ -3,12 +3,11 @@
 lib_LTLIBRARIES = libginac.la
 libginac_la_SOURCES = add.cpp basic.cpp constant.cpp diff.cpp ex.cpp \
   expairseq.cpp exprseq.cpp fail.cpp function.cpp inifcns.cpp \
-  inifcns_trans.cpp inifcns_gamma.cpp matrix.cpp mul.cpp normal.cpp \
-  numeric.cpp operators.cpp power.cpp print.cpp printraw.cpp printtree.cpp \
-  printcsrc.cpp relational.cpp symbol.cpp utils.cpp series.cpp ncmul.cpp \
-  clifford.cpp structure.cpp color.cpp indexed.cpp idx.cpp isospin.cpp \
-  exprseq_suppl.cpp lst.cpp lst_suppl.cpp simp_lor.cpp coloridx.cpp \
-  lorentzidx.cpp debugmsg.h utils.h
+  inifcns_trans.cpp inifcns_zeta.cpp inifcns_gamma.cpp matrix.cpp mul.cpp \
+  normal.cpp numeric.cpp operators.cpp power.cpp relational.cpp symbol.cpp \
+  utils.cpp series.cpp ncmul.cpp clifford.cpp structure.cpp color.cpp \
+  indexed.cpp idx.cpp isospin.cpp exprseq_suppl.cpp lst.cpp lst_suppl.cpp \
+  simp_lor.cpp coloridx.cpp lorentzidx.cpp debugmsg.h utils.h
 libginac_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
   -release $(LT_RELEASE)
 ginacincludedir = $(includedir)/ginac
@@ -28,3 +27,6 @@ lst.h lst.cpp: container.pl
 
 exprseq.h exprseq.cpp: container.pl
        perl container.pl exprseq
+
+# Force build of headers before compilation
+add.cpp: function.h lst.h exprseq.h