]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
- building GiNaC in a separate directory now works
[ginac.git] / ginac / Makefile.am
index 1035e836d984e493da597bb96518f0669b34ec98..271230936f9a8020c6d9c68103e3c686cbd40514 100644 (file)
@@ -21,14 +21,14 @@ ginacinclude_HEADERS = ginac.h add.h archive.h basic.h clifford.h color.h \
 EXTRA_DIST = container.pl function.pl structure.pl
 
 # Files which are generated by perl scripts
-function.h function.cpp: function.pl
-       perl function.pl
+$(srcdir)/function.h $(srcdir)/function.cpp: $(srcdir)/function.pl
+       cd $(srcdir) && perl function.pl
 
-lst.h lst.cpp: container.pl
-       perl container.pl lst
+$(srcdir)/lst.h $(srcdir)/lst.cpp: $(srcdir)/container.pl
+       cd $(srcdir) && perl container.pl lst
 
-exprseq.h exprseq.cpp: container.pl
-       perl container.pl exprseq
+$(srcdir)/exprseq.h $(srcdir)/exprseq.cpp: $(srcdir)/container.pl
+       cd $(srcdir) && perl container.pl exprseq
 
 # Force build of headers before compilation
-add.cpp: function.h lst.h exprseq.h
+$(srcdir)/add.cpp: $(srcdir)/function.h $(srcdir)/lst.h $(srcdir)/exprseq.h