]> www.ginac.de Git - ginac.git/blobdiff - ginac/Makefile.am
Modernized configuration files [A.Sheplyakov].
[ginac.git] / ginac / Makefile.am
index 7fa8b6ed54c1b9a1b226753681a943478ea921d0..0236f9b2db26746fbd4d403fcd31d3e4a2860c3c 100644 (file)
@@ -4,23 +4,22 @@ lib_LTLIBRARIES = libginac.la
 libginac_la_SOURCES = add.cpp archive.cpp basic.cpp clifford.cpp color.cpp \
   constant.cpp ex.cpp expair.cpp expairseq.cpp exprseq.cpp fail.cpp \
   fderivative.cpp function.cpp idx.cpp indexed.cpp inifcns.cpp \
-  inifcns_trans.cpp inifcns_zeta.cpp inifcns_gamma.cpp inifcns_nstdsums.cpp \
-  lst.cpp matrix.cpp mul.cpp ncmul.cpp normal.cpp numeric.cpp operators.cpp \
-  power.cpp registrar.cpp relational.cpp remember.cpp pseries.cpp print.cpp \
-  structure.cpp symbol.cpp symmetry.cpp tensor.cpp utils.cpp wildcard.cpp \
-  input_parser.yy input_lexer.ll \
+  inifcns_trans.cpp inifcns_gamma.cpp inifcns_nstdsums.cpp \
+  integral.cpp lst.cpp matrix.cpp mul.cpp ncmul.cpp normal.cpp numeric.cpp \
+  operators.cpp power.cpp registrar.cpp relational.cpp remember.cpp \
+  pseries.cpp print.cpp structure.cpp symbol.cpp symmetry.cpp tensor.cpp \
+  utils.cpp wildcard.cpp input_parser.yy input_lexer.ll \
   input_lexer.h remember.h tostring.h utils.h
-libginac_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-  -release $(LT_RELEASE)
+libginac_la_LDFLAGS = -version-info $(LT_VERSION_INFO) -release $(LT_RELEASE)
 ginacincludedir = $(includedir)/ginac
 ginacinclude_HEADERS = ginac.h add.h archive.h assertion.h basic.h class_info.h \
   clifford.h color.h constant.h container.h ex.h expair.h expairseq.h exprseq.h \
-  fail.h fderivative.h flags.h function.h idx.h indexed.h inifcns.h lst.h \
-  matrix.h mul.h ncmul.h normal.h numeric.h operators.h power.h print.h \
-  pseries.h ptr.h registrar.h relational.h structure.h symbol.h symmetry.h \
-  tensor.h tinfos.h version.h wildcard.h
-LFLAGS = -Pginac_yy -olex.yy.c
-YFLAGS = -p ginac_yy -d
+  fail.h fderivative.h flags.h function.h hash_map.h idx.h indexed.h inifcns.h \
+  integral.h lst.h matrix.h mul.h ncmul.h normal.h numeric.h operators.h \
+  power.h print.h pseries.h ptr.h registrar.h relational.h structure.h \
+  symbol.h symmetry.h tensor.h tinfos.h version.h wildcard.h
+AM_LFLAGS = -Pginac_yy -olex.yy.c
+AM_YFLAGS = -p ginac_yy -d
 EXTRA_DIST = function.pl input_parser.h version.h.in
 
 # Files which are generated by perl scripts