]> www.ginac.de Git - ginac.git/blobdiff - ginac/CMakeLists.txt
[build] Install compiler.h header file.
[ginac.git] / ginac / CMakeLists.txt
index 00824a49eb572e17146f450fb59dc7dba4fab134..27f4db8d8a5d56c9dbeeaace4df978e651e7c288 100644 (file)
@@ -71,6 +71,7 @@ set(ginaclib_public_headers
     class_info.h
     clifford.h
     color.h
+    compiler.h
     constant.h
     container.h
     ex.h
@@ -116,7 +117,6 @@ set(ginaclib_private_headers
     utils.h
     crc32.h
     hash_seed.h
-    compiler.h
     parser/lexer.h
     parser/debug.h
     polynomial/gcd_euclid.h
@@ -147,6 +147,7 @@ set(ginaclib_private_headers
 )
 
 add_library(ginac ${ginaclib_sources})
+add_definitions(-DLIBEXECDIR="${LIBEXECDIR}/")
 set_target_properties(ginac PROPERTIES
        SOVERSION ${ginaclib_soversion}
        VERSION ${ginaclib_version})