]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
Added `degree_vector' utility function.
[ginac.git] / doc / tutorial / Makefile.am
index d3c1afa06ba2cb15a5d607f3e7f497b144ddb14a..d855fda6aec746bccc8faf6fe877098655e3506c 100644 (file)
@@ -1,53 +1,41 @@
 ## Process this file with automake to produce Makefile.in
 
-# Graphics file conversion
 FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
-PNG = $(addsuffix .png, $(basename $(FIG)))
-EPS = $(addsuffix .eps, $(basename $(FIG)))
-TXT = $(addsuffix .txt, $(basename $(FIG)))
+info_TEXINFOS =
+AM_MAKEINFOHTMLFLAGS = --no-split
+
+if CONFIG_TEX
+if CONFIG_FIG2DEV
+
+# Graphics file conversion
+PNG = classhierarchy.png repnaive.png reppair.png repreal.png
+EPS = classhierarchy.eps repnaive.eps reppair.eps repreal.eps
+PDF = classhierarchy.pdf repnaive.pdf reppair.pdf repreal.pdf
 
-SUFFIXES = .fig .png .eps .txt
+SUFFIXES = .fig .png .eps
 
 .fig.eps:
-       @if [ "${FIG2DEV}" ]; then \
          echo "Running ${FIG2DEV} -L eps -m 0.9 $< $@..."; \
-         ${FIG2DEV} -L eps -m 0.9 $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
+         ${FIG2DEV} -L eps -m 0.9 $< $@;
+
+.fig.pdf:
+         echo "Running ${FIG2DEV} -L pdf -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L pdf -m 0.9 $< $@
 
 .fig.png:
-       @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L png $< $@..."; \
-         ${FIG2DEV} -L png $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
+       @echo "Running ${FIG2DEV} -L png $< $@..."; \
+         ${FIG2DEV} -L png $< $@
 
-info_TEXINFOS = ginac.texi
 
-ginac.dvi: $(EPS)
+info_TEXINFOS += ginac.texi
 
-ginac.html: ginac.texi version.texi $(PNG)
-       $(MAKEINFO) --html $< -I ${srcdir}
-
-ginactutorialdir = `test -z "@TUTORIAL_TARGETS@" || echo @datadir@/doc/GiNaC/tutorial`
-ginactutorial_DATA = @TUTORIAL_TARGETS@
-
-CLEANFILES = $(EPS) $(PNG) ginac.html
-EXTRA_DIST = $(FIG) $(TXT)
-
-install-data-local:
-       $(mkinstalldirs) $(DESTDIR)$(ginactutorialdir)
-       @for p in $(PNG); do \
-          if [ -f $$p ]; then \
-           echo " $(INSTALL_DATA) $$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-           $(INSTALL_DATA) $$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-         fi; \
-       done
-
-uninstall-local:
-       @for p in $(PNG); do \
-         echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-         rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-       done
+ginac.pdf: $(PDF)
+ginac.dvi: $(EPS)
+ginac.html: $(PNG)
+CLEANFILES = $(EPS) $(PDF) $(PNG)
+## CONFIG_FIG2DEV
+endif
+## CONFIG_TEX
+endif
+
+EXTRA_DIST = $(FIG)