]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
pgcd(): detect relatively prime polynomials properly...
[ginac.git] / doc / tutorial / Makefile.am
index c9025d9aa683d37f3a801735394457d7b57187ee..d855fda6aec746bccc8faf6fe877098655e3506c 100644 (file)
@@ -1,45 +1,41 @@
 ## Process this file with automake to produce Makefile.in
 
+FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
+info_TEXINFOS =
 AM_MAKEINFOHTMLFLAGS = --no-split
 
+if CONFIG_TEX
+if CONFIG_FIG2DEV
+
 # Graphics file conversion
-FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
-PNG = $(addsuffix .png, $(basename $(FIG)))
-EPS = $(addsuffix .eps, $(basename $(FIG)))
-PDF = $(addsuffix .pdf, $(basename $(FIG)))
-TXT = $(addsuffix .txt, $(basename $(FIG)))
+PNG = classhierarchy.png repnaive.png reppair.png repreal.png
+EPS = classhierarchy.eps repnaive.eps reppair.eps repreal.eps
+PDF = classhierarchy.pdf repnaive.pdf reppair.pdf repreal.pdf
 
-SUFFIXES = .fig .png .eps .txt
+SUFFIXES = .fig .png .eps
 
 .fig.eps:
-       @if [ "${FIG2DEV}" ]; then \
          echo "Running ${FIG2DEV} -L eps -m 0.9 $< $@..."; \
-         ${FIG2DEV} -L eps -m 0.9 $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
+         ${FIG2DEV} -L eps -m 0.9 $< $@;
 
 .fig.pdf:
-       @if [ "${FIG2DEV}" ]; then \
          echo "Running ${FIG2DEV} -L pdf -m 0.9 $< $@..."; \
-         ${FIG2DEV} -L pdf -m 0.9 $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
+         ${FIG2DEV} -L pdf -m 0.9 $< $@
 
 .fig.png:
-       @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L png $< $@..."; \
-         ${FIG2DEV} -L png $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
+       @echo "Running ${FIG2DEV} -L png $< $@..."; \
+         ${FIG2DEV} -L png $< $@
 
-info_TEXINFOS = ginac.texi
+
+info_TEXINFOS += ginac.texi
 
 ginac.pdf: $(PDF)
 ginac.dvi: $(EPS)
 ginac.html: $(PNG)
-
 CLEANFILES = $(EPS) $(PDF) $(PNG)
-EXTRA_DIST = $(FIG) $(TXT)
+## CONFIG_FIG2DEV
+endif
+## CONFIG_TEX
+endif
+
+EXTRA_DIST = $(FIG)