]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
Make new tinfo-system work on AMD64.
[ginac.git] / doc / tutorial / Makefile.am
index af8ac282504dd2ca4f107e52b6eda7d45495161f..c9025d9aa683d37f3a801735394457d7b57187ee 100644 (file)
@@ -1,9 +1,12 @@
 ## Process this file with automake to produce Makefile.in
 
+AM_MAKEINFOHTMLFLAGS = --no-split
+
 # Graphics file conversion
 FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
 PNG = $(addsuffix .png, $(basename $(FIG)))
 EPS = $(addsuffix .eps, $(basename $(FIG)))
+PDF = $(addsuffix .pdf, $(basename $(FIG)))
 TXT = $(addsuffix .txt, $(basename $(FIG)))
 
 SUFFIXES = .fig .png .eps .txt
@@ -16,6 +19,14 @@ SUFFIXES = .fig .png .eps .txt
          echo "warning: fig2dev was not found by configure"; \
        fi
 
+.fig.pdf:
+       @if [ "${FIG2DEV}" ]; then \
+         echo "Running ${FIG2DEV} -L pdf -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L pdf -m 0.9 $< $@; \
+       else \
+         echo "warning: fig2dev was not found by configure"; \
+       fi
+
 .fig.png:
        @if [ "${FIG2DEV}" ]; then \
          echo "Running ${FIG2DEV} -L png $< $@..."; \
@@ -26,28 +37,9 @@ SUFFIXES = .fig .png .eps .txt
 
 info_TEXINFOS = ginac.texi
 
+ginac.pdf: $(PDF)
 ginac.dvi: $(EPS)
+ginac.html: $(PNG)
 
-ginac.html: ginac.texi version.texi $(PNG)
-       $(MAKEINFO) --html $< -I ${srcdir}
-
-ginacdocdir = $(datadir)/doc/GiNaC
-ginactutorialdir = $(ginacdocdir)/tutorial
-ginactutorial_DATA = @TUTORIAL_TARGETS@
-
-CLEANFILES = $(EPS) $(PNG) ginac.html
+CLEANFILES = $(EPS) $(PDF) $(PNG)
 EXTRA_DIST = $(FIG) $(TXT)
-
-install-data-local:
-       @for p in $(PNG); do \
-          if [ -f $$p ]; then \
-           echo " $(INSTALL_DATA) $$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-           $(INSTALL_DATA) $$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-         fi; \
-       done
-
-uninstall-local:
-       @for p in $(PNG); do \
-         echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-         rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-       done