]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
Added compile function.
[ginac.git] / doc / tutorial / Makefile.am
index 50c49956a58a177720a571fb18b4159e2cf44ae5..c9025d9aa683d37f3a801735394457d7b57187ee 100644 (file)
@@ -1,21 +1,33 @@
 ## Process this file with automake to produce Makefile.in
 
+AM_MAKEINFOHTMLFLAGS = --no-split
+
 # Graphics file conversion
 FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
 PNG = $(addsuffix .png, $(basename $(FIG)))
 EPS = $(addsuffix .eps, $(basename $(FIG)))
+PDF = $(addsuffix .pdf, $(basename $(FIG)))
+TXT = $(addsuffix .txt, $(basename $(FIG)))
+
+SUFFIXES = .fig .png .eps .txt
 
-SUFFIXES = .fig .png .eps
+.fig.eps:
+       @if [ "${FIG2DEV}" ]; then \
+         echo "Running ${FIG2DEV} -L eps -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L eps -m 0.9 $< $@; \
+       else \
+         echo "warning: fig2dev was not found by configure"; \
+       fi
 
-%.eps: %.fig
+.fig.pdf:
        @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L ps -m 0.8 $< $@..."; \
-         ${FIG2DEV} -L ps -m 0.8 $< $@; \
+         echo "Running ${FIG2DEV} -L pdf -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L pdf -m 0.9 $< $@; \
        else \
          echo "warning: fig2dev was not found by configure"; \
        fi
 
-%.png: %.fig
+.fig.png:
        @if [ "${FIG2DEV}" ]; then \
          echo "Running ${FIG2DEV} -L png $< $@..."; \
          ${FIG2DEV} -L png $< $@; \
@@ -25,27 +37,9 @@ SUFFIXES = .fig .png .eps
 
 info_TEXINFOS = ginac.texi
 
+ginac.pdf: $(PDF)
 ginac.dvi: $(EPS)
+ginac.html: $(PNG)
 
-ginac.html: ginac.texi version.texi $(PNG)
-       cd $(srcdir) \
-         && $(MAKEINFO) --html `echo $< | sed 's,.*/,,'`
-
-ginacdocdir = $(datadir)/doc/GiNaC
-ginactutorialdir = $(ginacdocdir)/tutorial
-ginactutorial_DATA = @TUTORIAL_TARGETS@
-
-CLEANFILES = $(EPS) $(PNG) ginac.html
-EXTRA_DIST = $(FIG)
-
-install-data-local:
-       @for p in $(PNG); do \
-         echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-         $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-       done
-
-uninstall-local:
-       @for p in $(PNG); do \
-         echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-         rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-       done
+CLEANFILES = $(EPS) $(PDF) $(PNG)
+EXTRA_DIST = $(FIG) $(TXT)