]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
- Remove the -ansi compiler switch in the example since it doesn't
[ginac.git] / doc / tutorial / Makefile.am
index a2763b1c5a3f7154a74687073170f8378752d34d..af8ac282504dd2ca4f107e52b6eda7d45495161f 100644 (file)
@@ -8,15 +8,15 @@ TXT = $(addsuffix .txt, $(basename $(FIG)))
 
 SUFFIXES = .fig .png .eps .txt
 
-%.eps: %.fig
+.fig.eps:
        @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L ps -m 0.9 $< $@..."; \
-         ${FIG2DEV} -L ps -m 0.9 $< $@; \
+         echo "Running ${FIG2DEV} -L eps -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L eps -m 0.9 $< $@; \
        else \
          echo "warning: fig2dev was not found by configure"; \
        fi
 
-%.png: %.fig
+.fig.png:
        @if [ "${FIG2DEV}" ]; then \
          echo "Running ${FIG2DEV} -L png $< $@..."; \
          ${FIG2DEV} -L png $< $@; \
@@ -29,8 +29,7 @@ info_TEXINFOS = ginac.texi
 ginac.dvi: $(EPS)
 
 ginac.html: ginac.texi version.texi $(PNG)
-       cd $(srcdir) \
-         && $(MAKEINFO) --html `echo $< | sed 's,.*/,,'`
+       $(MAKEINFO) --html $< -I ${srcdir}
 
 ginacdocdir = $(datadir)/doc/GiNaC
 ginactutorialdir = $(ginacdocdir)/tutorial
@@ -41,9 +40,9 @@ EXTRA_DIST = $(FIG) $(TXT)
 
 install-data-local:
        @for p in $(PNG); do \
-          if [ -f $(srcdir)/$$p ]; then \
-           echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-           $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
+          if [ -f $$p ]; then \
+           echo " $(INSTALL_DATA) $$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
+           $(INSTALL_DATA) $$p $(DESTDIR)$(ginactutorialdir)/$$p; \
          fi; \
        done