]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
- added one more sample for our friends at NASA. :-)
[ginac.git] / doc / tutorial / Makefile.am
index 32455b87f8e2d0abe55a89f88624cc5b47d008f9..8749c7f098e679d62e1906cbd81bf48dc4ee3605 100644 (file)
@@ -5,7 +5,7 @@
 # some regexpese to tutorial.sgml prior to parsing it, in order to allow for
 # different graphics output.  This seems to be an ugly limitation of docbook...
 
-FIG = classhierarchy.fig rep_naive.fig rep_pair.fig
+FIG = classhierarchy.fig rep_naive.fig rep_pair.fig rep_real.fig
 PNG = $(addsuffix .png, $(basename $(FIG)))
 EPS = $(addsuffix .eps, $(basename $(FIG)))
 
@@ -32,7 +32,10 @@ JADEARGS_HTML = -t sgml -d /usr/lib/sgml/stylesheet/dsssl/docbook/nwalsh/html/do
 
 index.html: tutorial.sgml.in $(PNG)
        @if [ "${JADE}" ]; then \
-         sed -e 's/graext/png/g' -e 's/GRAEXT/GIF/g' tutorial.sgml.in > tutorial.sgml; \
+         sed -e "s/MAJOR_VERSION/${GINACLIB_MAJOR_VERSION}/" \
+             -e "s/MINOR_VERSION/${GINACLIB_MINOR_VERSION}/" \
+             -e 's/graext/png/g' \
+             -e 's/GRAEXT/GIF/g' tutorial.sgml.in > tutorial.sgml; \
          echo "Running ${JADE} ${JADEARGS_HTML} tutorial.sgml..."; \
          ${JADE} ${JADEARGS_HTML} tutorial.sgml; \
          if [ -f book1.html ]; then mv book1.html index.html; fi; \
@@ -42,7 +45,10 @@ index.html: tutorial.sgml.in $(PNG)
 
 tutorial.tex: tutorial.sgml.in $(EPS)
        @if [ "${JADE}" -a "${LATEX}" ]; then \
-         sed -e 's/graext/eps/g' -e 's/GRAEXT/EPS/g' tutorial.sgml.in > tutorial.sgml; \
+         sed -e "s/MAJOR_VERSION/${GINACLIB_MAJOR_VERSION}/" \
+             -e "s/MINOR_VERSION/${GINACLIB_MINOR_VERSION}/" \
+             -e 's/graext/eps/g' \
+             -e 's/GRAEXT/EPS/g' tutorial.sgml.in > tutorial.sgml; \
          echo "Running ${JADE} ${JADEARGS_TEX} tutorial.sgml..."; \
          ${JADE} ${JADEARGS_TEX} tutorial.sgml ; \
        else \
@@ -65,6 +71,14 @@ tutorial.ps: tutorial.dvi
          echo "warning: target tutorial.ps disabled by configuration"; \
        fi
 
+ginacdocdir = $(datadir)/doc/GiNaC
+ginactutorialdir = $(ginacdocdir)/tutorial
+ginactutorial_DATA = @TUTORIAL_TARGETS@
+EXTRA_DATA = index.html tutorial.ps
+
+CLEANFILES = *.html *.png *.ps *.tex *.log *.aux *.dvi *.eps tutorial.sgml HTML.manifest
+EXTRA_DIST = tutorial.sgml.in $(FIG)
+
 install-data-local:
        @for p in *.html; do \
          echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
@@ -84,11 +98,3 @@ uninstall-local:
          echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
          rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
        done
-
-ginacdocdir = $(datadir)/doc/GiNaC
-ginactutorialdir = $(ginacdocdir)/tutorial
-ginactutorial_DATA = $(TUTORIAL_TARGETS)
-EXTRA_DATA = index.html tutorial.ps
-
-CLEANFILES = *.html *.png *.ps *.tex *.log *.aux *.dvi *.eps tutorial.sgml HTML.manifest
-EXTRA_DIST = tutorial.sgml.in $(FIG)