]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
- corrected a bunch of typos.
[ginac.git] / doc / tutorial / Makefile.am
index 32455b87f8e2d0abe55a89f88624cc5b47d008f9..50c49956a58a177720a571fb18b4159e2cf44ae5 100644 (file)
@@ -1,11 +1,7 @@
 ## Process this file with automake to produce Makefile.in
 
 ## Process this file with automake to produce Makefile.in
 
-# This section produces HTML'ed and TeX'ed versions of the tutorial using a
-# SGML to TeX converter (in this case jade).  As a dirty hack, we are doing
-# some regexpese to tutorial.sgml prior to parsing it, in order to allow for
-# different graphics output.  This seems to be an ugly limitation of docbook...
-
-FIG = classhierarchy.fig rep_naive.fig rep_pair.fig
+# Graphics file conversion
+FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
 PNG = $(addsuffix .png, $(basename $(FIG)))
 EPS = $(addsuffix .eps, $(basename $(FIG)))
 
 PNG = $(addsuffix .png, $(basename $(FIG)))
 EPS = $(addsuffix .eps, $(basename $(FIG)))
 
@@ -27,68 +23,29 @@ SUFFIXES = .fig .png .eps
          echo "warning: fig2dev was not found by configure"; \
        fi
 
          echo "warning: fig2dev was not found by configure"; \
        fi
 
-JADEARGS_TEX = -t tex -o tutorial.tex -d /usr/lib/sgml/stylesheet/dsssl/docbook/nwalsh/print/docbook.dsl
-JADEARGS_HTML = -t sgml -d /usr/lib/sgml/stylesheet/dsssl/docbook/nwalsh/html/docbook.dsl
+info_TEXINFOS = ginac.texi
 
 
-index.html: tutorial.sgml.in $(PNG)
-       @if [ "${JADE}" ]; then \
-         sed -e 's/graext/png/g' -e 's/GRAEXT/GIF/g' tutorial.sgml.in > tutorial.sgml; \
-         echo "Running ${JADE} ${JADEARGS_HTML} tutorial.sgml..."; \
-         ${JADE} ${JADEARGS_HTML} tutorial.sgml; \
-         if [ -f book1.html ]; then mv book1.html index.html; fi; \
-       else \
-         echo "warning: target tutorial_html disabled by configuration"; \
-       fi
+ginac.dvi: $(EPS)
 
 
-tutorial.tex: tutorial.sgml.in $(EPS)
-       @if [ "${JADE}" -a "${LATEX}" ]; then \
-         sed -e 's/graext/eps/g' -e 's/GRAEXT/EPS/g' tutorial.sgml.in > tutorial.sgml; \
-         echo "Running ${JADE} ${JADEARGS_TEX} tutorial.sgml..."; \
-         ${JADE} ${JADEARGS_TEX} tutorial.sgml ; \
-       else \
-         echo "warning: target tutorial.tex disabled by configuration"; \
-       fi
+ginac.html: ginac.texi version.texi $(PNG)
+       cd $(srcdir) \
+         && $(MAKEINFO) --html `echo $< | sed 's,.*/,,'`
 
 
-tutorial.dvi: tutorial.tex
-       @if [ "${JADETEX}" ]; then \
-         echo "Running ${JADETEX} tutorial.tex..."; \
-         ${JADETEX} tutorial.tex && ${JADETEX} tutorial.tex && ${JADETEX} tutorial.tex; \
-       else \
-         echo "warning: target tutorial.dvi disabled by configuration"; \
-       fi
+ginacdocdir = $(datadir)/doc/GiNaC
+ginactutorialdir = $(ginacdocdir)/tutorial
+ginactutorial_DATA = @TUTORIAL_TARGETS@
 
 
-tutorial.ps: tutorial.dvi
-       @if [ "${DVIPS}" ]; then \
-         echo "Running ${DVIPS} tutorial.dvi -o tutorial.ps..."; \
-         ${DVIPS} tutorial.dvi -o tutorial.ps; \
-       else \
-         echo "warning: target tutorial.ps disabled by configuration"; \
-       fi
+CLEANFILES = $(EPS) $(PNG) ginac.html
+EXTRA_DIST = $(FIG)
 
 install-data-local:
 
 install-data-local:
-       @for p in *.html; do \
-         echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-         $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-       done
-       @for p in *.png; do \
+       @for p in $(PNG); do \
          echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
          $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
        done
 
 uninstall-local:
          echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
          $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
        done
 
 uninstall-local:
-       @for p in *.html; do \
-         echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-         rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-       done
-       @for p in *.png; do \
+       @for p in $(PNG); do \
          echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
          rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
        done
          echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
          rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
        done
-
-ginacdocdir = $(datadir)/doc/GiNaC
-ginactutorialdir = $(ginacdocdir)/tutorial
-ginactutorial_DATA = $(TUTORIAL_TARGETS)
-EXTRA_DATA = index.html tutorial.ps
-
-CLEANFILES = *.html *.png *.ps *.tex *.log *.aux *.dvi *.eps tutorial.sgml HTML.manifest
-EXTRA_DIST = tutorial.sgml.in $(FIG)