]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
* Documented sqrfree.
[ginac.git] / doc / tutorial / Makefile.am
index 44be9f82f6ec8a5f2ea13b09e74beb19abafc692..2ddabe8ee4152e594b854e20bf20d1b6f00237bd 100644 (file)
@@ -4,21 +4,22 @@
 FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
 PNG = $(addsuffix .png, $(basename $(FIG)))
 EPS = $(addsuffix .eps, $(basename $(FIG)))
+TXT = $(addsuffix .txt, $(basename $(FIG)))
 
-SUFFIXES = .fig .png .eps
+SUFFIXES = .fig .png .eps .txt
 
-%.eps: %.fig
+.fig.eps:
        @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L ps -m 0.8 $< $@..."; \
-         ${FIG2DEV} -L ps -m 0.8 $< $@; \
+         echo "Running ${FIG2DEV} -L eps -m 0.9 $< $@..."; \
+         cd $(srcdir) && ${FIG2DEV} -L eps -m 0.9 $< $@; \
        else \
          echo "warning: fig2dev was not found by configure"; \
        fi
 
-%.png: %.fig
+.fig.png:
        @if [ "${FIG2DEV}" ]; then \
          echo "Running ${FIG2DEV} -L png $< $@..."; \
-         ${FIG2DEV} -L png $< $@; \
+         cd $(srcdir) && ${FIG2DEV} -L png $< $@; \
        else \
          echo "warning: fig2dev was not found by configure"; \
        fi
@@ -35,27 +36,19 @@ ginacdocdir = $(datadir)/doc/GiNaC
 ginactutorialdir = $(ginacdocdir)/tutorial
 ginactutorial_DATA = @TUTORIAL_TARGETS@
 
-CLEANFILES = $(EPS) $(PNG) *.html
-EXTRA_DIST = $(FIG)
-
-#CLEANFILES = *.html *.png *.ps *.tex *.log *.aux *.dvi *.eps tutorial.sgml HTML.manifest
-
-#install-data-local:
-#      @for p in *.html; do \
-#        echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-#        $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-#      done
-#      @for p in *.png; do \
-#        echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-#        $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-#      done
-
-#uninstall-local:
-#      @for p in *.html; do \
-#        echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-#        rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-#      done
-#      @for p in *.png; do \
-#        echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-#        rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-#      done
+CLEANFILES = $(EPS) $(PNG) ginac.html
+EXTRA_DIST = $(FIG) $(TXT)
+
+install-data-local:
+       @for p in $(PNG); do \
+          if [ -f $(srcdir)/$$p ]; then \
+           echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
+           $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
+         fi; \
+       done
+
+uninstall-local:
+       @for p in $(PNG); do \
+         echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
+         rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
+       done