]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
Update debian/changelog in anticipation of release.
[ginac.git] / doc / tutorial / Makefile.am
index fc1e74b9be436d4dd1c9f318d73aaac8f301b1ea..2d23965fae29d51bb2a190e1f49184922986bb90 100644 (file)
@@ -1,54 +1,42 @@
 ## Process this file with automake to produce Makefile.in
 
-# Graphics file conversion
 FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
+TXT = $(addsuffix .txt, $(basename $(FIG)))
+info_TEXINFOS =
+AM_MAKEINFOHTMLFLAGS = --no-split
+
+if CONFIG_TEX
+if CONFIG_FIG2DEV
+
+# Graphics file conversion
 PNG = $(addsuffix .png, $(basename $(FIG)))
 EPS = $(addsuffix .eps, $(basename $(FIG)))
-TXT = $(addsuffix .txt, $(basename $(FIG)))
+PDF = $(addsuffix .pdf, $(basename $(FIG)))
 
 SUFFIXES = .fig .png .eps .txt
 
-%.eps: %.fig
-       @if [ "${FIG2DEV}" ]; then \
+.fig.eps:
          echo "Running ${FIG2DEV} -L eps -m 0.9 $< $@..."; \
-         ${FIG2DEV} -L eps -m 0.9 $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
+         ${FIG2DEV} -L eps -m 0.9 $< $@;
 
-%.png: %.fig
-       @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L png $< $@..."; \
-         ${FIG2DEV} -L png $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
+.fig.pdf:
+         echo "Running ${FIG2DEV} -L pdf -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L pdf -m 0.9 $< $@
 
-info_TEXINFOS = ginac.texi
+.fig.png:
+       @echo "Running ${FIG2DEV} -L png $< $@..."; \
+         ${FIG2DEV} -L png $< $@
 
-ginac.dvi: $(EPS)
 
-ginac.html: ginac.texi version.texi $(PNG)
-       cd $(srcdir) \
-         && $(MAKEINFO) --html `echo $< | sed 's,.*/,,'`
+info_TEXINFOS += ginac.texi
 
-ginacdocdir = $(datadir)/doc/GiNaC
-ginactutorialdir = $(ginacdocdir)/tutorial
-ginactutorial_DATA = @TUTORIAL_TARGETS@
+ginac.pdf: $(PDF)
+ginac.dvi: $(EPS)
+ginac.html: $(PNG)
+CLEANFILES = $(EPS) $(PDF) $(PNG)
+## CONFIG_FIG2DEV
+endif
+## CONFIG_TEX
+endif
 
-CLEANFILES = $(EPS) $(PNG) ginac.html
 EXTRA_DIST = $(FIG) $(TXT)
-
-install-data-local:
-       @for p in $(PNG); do \
-          if [ -f $(srcdir)/$$p ]; then \
-           echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-           $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-         fi; \
-       done
-
-uninstall-local:
-       @for p in $(PNG); do \
-         echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-         rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-       done