]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
Remove 'level' argument of evalf().
[ginac.git] / doc / tutorial / Makefile.am
index a2763b1c5a3f7154a74687073170f8378752d34d..14d333650c52ef0d0c3c76f8c2e4a5093d90bdb8 100644 (file)
@@ -1,54 +1,41 @@
 ## Process this file with automake to produce Makefile.in
 
-# Graphics file conversion
 FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
-PNG = $(addsuffix .png, $(basename $(FIG)))
-EPS = $(addsuffix .eps, $(basename $(FIG)))
-TXT = $(addsuffix .txt, $(basename $(FIG)))
-
-SUFFIXES = .fig .png .eps .txt
-
-%.eps: %.fig
-       @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L ps -m 0.9 $< $@..."; \
-         ${FIG2DEV} -L ps -m 0.9 $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
-
-%.png: %.fig
-       @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L png $< $@..."; \
-         ${FIG2DEV} -L png $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
-
-info_TEXINFOS = ginac.texi
+info_TEXINFOS =
+AM_MAKEINFOHTMLFLAGS = --no-split
 
-ginac.dvi: $(EPS)
+if CONFIG_TEX
+if CONFIG_FIG2DEV
+
+# Graphics file conversion
+PNG = classhierarchy.png repnaive.png reppair.png repreal.png
+EPS = classhierarchy.eps repnaive.eps reppair.eps repreal.eps
+PDF = classhierarchy.pdf repnaive.pdf reppair.pdf repreal.pdf
+
+SUFFIXES = .fig .png .eps
+
+.fig.eps:
+         echo "Running ${FIG2DEV} -L eps -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L eps -m 0.9 $< $@;
 
-ginac.html: ginac.texi version.texi $(PNG)
-       cd $(srcdir) \
-         && $(MAKEINFO) --html `echo $< | sed 's,.*/,,'`
-
-ginacdocdir = $(datadir)/doc/GiNaC
-ginactutorialdir = $(ginacdocdir)/tutorial
-ginactutorial_DATA = @TUTORIAL_TARGETS@
-
-CLEANFILES = $(EPS) $(PNG) ginac.html
-EXTRA_DIST = $(FIG) $(TXT)
-
-install-data-local:
-       @for p in $(PNG); do \
-          if [ -f $(srcdir)/$$p ]; then \
-           echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-           $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-         fi; \
-       done
-
-uninstall-local:
-       @for p in $(PNG); do \
-         echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-         rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-       done
+.fig.pdf:
+         echo "Running ${FIG2DEV} -L pdf -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L pdf -m 0.9 $< $@
+
+.fig.png:
+       @echo "Running ${FIG2DEV} -L png $< $@..."; \
+         ${FIG2DEV} -L png $< $@
+
+
+info_TEXINFOS += ginac.texi
+
+ginac.pdf: $(PDF)
+ginac.dvi: $(EPS)
+ginac.html: $(PNG)
+CLEANFILES = $(EPS) $(PDF) $(PNG)
+## CONFIG_FIG2DEV
+endif
+## CONFIG_TEX
+endif
+
+EXTRA_DIST = $(FIG) CMakeLists.txt version.texi.cmake