]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
Remove 'level' argument of evalf().
[ginac.git] / doc / tutorial / Makefile.am
index 44be9f82f6ec8a5f2ea13b09e74beb19abafc692..14d333650c52ef0d0c3c76f8c2e4a5093d90bdb8 100644 (file)
@@ -1,61 +1,41 @@
 ## Process this file with automake to produce Makefile.in
 
-# Graphics file conversion
 FIG = classhierarchy.fig repnaive.fig reppair.fig repreal.fig
-PNG = $(addsuffix .png, $(basename $(FIG)))
-EPS = $(addsuffix .eps, $(basename $(FIG)))
+info_TEXINFOS =
+AM_MAKEINFOHTMLFLAGS = --no-split
+
+if CONFIG_TEX
+if CONFIG_FIG2DEV
+
+# Graphics file conversion
+PNG = classhierarchy.png repnaive.png reppair.png repreal.png
+EPS = classhierarchy.eps repnaive.eps reppair.eps repreal.eps
+PDF = classhierarchy.pdf repnaive.pdf reppair.pdf repreal.pdf
 
 SUFFIXES = .fig .png .eps
 
-%.eps: %.fig
-       @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L ps -m 0.8 $< $@..."; \
-         ${FIG2DEV} -L ps -m 0.8 $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
+.fig.eps:
+         echo "Running ${FIG2DEV} -L eps -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L eps -m 0.9 $< $@;
 
-%.png: %.fig
-       @if [ "${FIG2DEV}" ]; then \
-         echo "Running ${FIG2DEV} -L png $< $@..."; \
-         ${FIG2DEV} -L png $< $@; \
-       else \
-         echo "warning: fig2dev was not found by configure"; \
-       fi
+.fig.pdf:
+         echo "Running ${FIG2DEV} -L pdf -m 0.9 $< $@..."; \
+         ${FIG2DEV} -L pdf -m 0.9 $< $@
 
-info_TEXINFOS = ginac.texi
+.fig.png:
+       @echo "Running ${FIG2DEV} -L png $< $@..."; \
+         ${FIG2DEV} -L png $< $@
 
-ginac.dvi: $(EPS)
 
-ginac.html: ginac.texi version.texi $(PNG)
-       cd $(srcdir) \
-         && $(MAKEINFO) --html `echo $< | sed 's,.*/,,'`
-
-ginacdocdir = $(datadir)/doc/GiNaC
-ginactutorialdir = $(ginacdocdir)/tutorial
-ginactutorial_DATA = @TUTORIAL_TARGETS@
-
-CLEANFILES = $(EPS) $(PNG) *.html
-EXTRA_DIST = $(FIG)
-
-#CLEANFILES = *.html *.png *.ps *.tex *.log *.aux *.dvi *.eps tutorial.sgml HTML.manifest
-
-#install-data-local:
-#      @for p in *.html; do \
-#        echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-#        $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-#      done
-#      @for p in *.png; do \
-#        echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-#        $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
-#      done
-
-#uninstall-local:
-#      @for p in *.html; do \
-#        echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-#        rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-#      done
-#      @for p in *.png; do \
-#        echo " rm -f $(DESTDIR)$(ginactutorialdir)/$$p"; \
-#        rm -f $(DESTDIR)$(ginactutorialdir)/$$p; \
-#      done
+info_TEXINFOS += ginac.texi
+
+ginac.pdf: $(PDF)
+ginac.dvi: $(EPS)
+ginac.html: $(PNG)
+CLEANFILES = $(EPS) $(PDF) $(PNG)
+## CONFIG_FIG2DEV
+endif
+## CONFIG_TEX
+endif
+
+EXTRA_DIST = $(FIG) CMakeLists.txt version.texi.cmake