]> www.ginac.de Git - ginac.git/blobdiff - doc/tutorial/Makefile.am
building DVI/PS in separate directory now works
[ginac.git] / doc / tutorial / Makefile.am
index 2ddabe8ee4152e594b854e20bf20d1b6f00237bd..af8ac282504dd2ca4f107e52b6eda7d45495161f 100644 (file)
@@ -11,7 +11,7 @@ SUFFIXES = .fig .png .eps .txt
 .fig.eps:
        @if [ "${FIG2DEV}" ]; then \
          echo "Running ${FIG2DEV} -L eps -m 0.9 $< $@..."; \
-         cd $(srcdir) && ${FIG2DEV} -L eps -m 0.9 $< $@; \
+         ${FIG2DEV} -L eps -m 0.9 $< $@; \
        else \
          echo "warning: fig2dev was not found by configure"; \
        fi
@@ -19,7 +19,7 @@ SUFFIXES = .fig .png .eps .txt
 .fig.png:
        @if [ "${FIG2DEV}" ]; then \
          echo "Running ${FIG2DEV} -L png $< $@..."; \
-         cd $(srcdir) && ${FIG2DEV} -L png $< $@; \
+         ${FIG2DEV} -L png $< $@; \
        else \
          echo "warning: fig2dev was not found by configure"; \
        fi
@@ -29,8 +29,7 @@ info_TEXINFOS = ginac.texi
 ginac.dvi: $(EPS)
 
 ginac.html: ginac.texi version.texi $(PNG)
-       cd $(srcdir) \
-         && $(MAKEINFO) --html `echo $< | sed 's,.*/,,'`
+       $(MAKEINFO) --html $< -I ${srcdir}
 
 ginacdocdir = $(datadir)/doc/GiNaC
 ginactutorialdir = $(ginacdocdir)/tutorial
@@ -41,9 +40,9 @@ EXTRA_DIST = $(FIG) $(TXT)
 
 install-data-local:
        @for p in $(PNG); do \
-          if [ -f $(srcdir)/$$p ]; then \
-           echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
-           $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(ginactutorialdir)/$$p; \
+          if [ -f $$p ]; then \
+           echo " $(INSTALL_DATA) $$p $(DESTDIR)$(ginactutorialdir)/$$p"; \
+           $(INSTALL_DATA) $$p $(DESTDIR)$(ginactutorialdir)/$$p; \
          fi; \
        done