]> www.ginac.de Git - ginac.git/blobdiff - doc/examples/Makefile.am
[bugfix] remainder_in_ring: using exact division is plain wrong.
[ginac.git] / doc / examples / Makefile.am
index c88a8212f19a2e4eefbdb7ae9a3fa8d158fb04cb..2a5a10888d18e5cc97374c409f34fe16c60d8674 100644 (file)
@@ -1,13 +1,19 @@
 ## Process this file with automake to produce Makefile.in
 
-EXFILES = archive1.cpp
+EXFILES = archive1.cpp compile1.cpp compile2.cpp compile3.cpp lanczos.cpp \
+ mystring.cpp derivative.cpp
 
-TEXINFO_TEX = ../tutorial/texinfo.tex
+TEXI = ginac-examples.texi
 
-info_TEXINFOS = ginac-examples.texi
+info_TEXINFOS = $(TEXI)
+
+TXT = ginac-examples.txt
+HTML = ginac-examples.html
 
 all: $(EXFILES)
-       ${MAKEINFO} --no-split --no-headers $(srcdir)/ginac-examples.texi > ginac-examples.txt
-       ${MAKEINFO} --no-split --html $(srcdir)/ginac-examples.texi
+       ${MAKEINFO} --no-split --no-headers $(srcdir)/$(TEXI) > $(TXT)
+       ${MAKEINFO} --no-split --html $(srcdir)/$(TEXI)
+
+CLEANFILES = $(TXT) $(HTML)
 
 EXTRA_DIST = $(EXFILES)