]> www.ginac.de Git - ginac.git/blobdiff - doc/examples/Makefile.am
Fixed make distcheck issues.
[ginac.git] / doc / examples / Makefile.am
index c88a8212f19a2e4eefbdb7ae9a3fa8d158fb04cb..06bf854e3cd342f530cd4364804076f52deada6f 100644 (file)
@@ -1,13 +1,19 @@
 ## Process this file with automake to produce Makefile.in
 
-EXFILES = archive1.cpp
+EXFILES = archive1.cpp compile1.cpp compile2.cpp compile3.cpp lanczos.cpp \
+ mystring.cpp
 
-TEXINFO_TEX = ../tutorial/texinfo.tex
+TEXI = ginac-examples.texi
 
-info_TEXINFOS = ginac-examples.texi
+info_TEXINFOS = $(TEXI)
+
+TXT = $(addsuffix .txt, $(basename $(TEXI)))
+HTML = $(addsuffix .html, $(basename $(TEXI)))
 
 all: $(EXFILES)
-       ${MAKEINFO} --no-split --no-headers $(srcdir)/ginac-examples.texi > ginac-examples.txt
-       ${MAKEINFO} --no-split --html $(srcdir)/ginac-examples.texi
+       ${MAKEINFO} --no-split --no-headers $(srcdir)/$(TEXI) > $(TXT)
+       ${MAKEINFO} --no-split --html $(srcdir)/$(TEXI)
+
+CLEANFILES = $(TXT) $(HTML)
 
 EXTRA_DIST = $(EXFILES)