]> www.ginac.de Git - ginac.git/blobdiff - debian/rules
More file cleanups
[ginac.git] / debian / rules
index e6493b5b2f3c869350829d17e51f0116222c7576..eec20aea89b1765d996a2172af55587a9dc8529b 100755 (executable)
@@ -9,24 +9,8 @@ version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
 
 build:
        dh_testdir
-       ./configure --prefix=/usr
-
-       -mkdir shared static
-       #
-       # First build the shared library
-       #
-       cd shared ; \
-           $(MAKE) -f ../Makefile VPATH=".." srcdir=".." \
-               CFLAGS="-O2 -fPIC -pipe" ; \
-           gcc -shared -Wl,-soname,$(package).so.$(version_major) -o $(package).so.$(version) `ls *.o`
-       #
-       # Build the static library (it does not need Position Independent Code,
-       # which reserves one register; thus, without -fPIC we get more efficient
-       # code).
-       #
-       cd static ; \
-            $(MAKE) -f ../Makefile VPATH=".." srcdir=".." \
-                 CFLAGS="-O2 -pipe" LDFLAGS="-s" progs
+       ./configure --without-cint --prefix=/usr
+       $(MAKE) CXXFLAGS="-O2"
        touch build
 
 clean:
@@ -40,27 +24,29 @@ clean:
 
 binary-indep: build
        dh_testdir
-# There are no architecture-independent files to be uploaded
-# generated by this package.  If there were any they would be
-# made here.
+       dh_testroot
 
 binary-arch: build
        dh_testdir
-       -rm -rf debian/tmp `find debian/* -type d`
-       install -d debian/tmp
-       cd debian/tmp && install -d `cat ../dirs`
-       install -m644 static/$(package).a debian/tmp/usr/lib/
-       install -m644 static/gdbm.h dbm.h ndbm.h debian/tmp/usr/include/
-       install -m644 gdbm.3 debian/tmp/usr/share/man/man3/gdbm.3gdbm
-
-       install -m644 shared/$(package).so.$(version) debian/tmp/usr/lib
-
-       $(MAKE) install prefix=`pwd`/debian/tmp/usr
-       debstd -m ChangeLog NEWS README 
-       dpkg-gencontrol -pginac1-dev
-       chown -R root.root debian/tmp
-       chmod -R go=rX debian/tmp
-       dpkg --build debian/tmp ..
+       dh_testroot
+       dh_installdirs
+       # When will Automake honor FHS?
+       $(MAKE) install prefix=`pwd`/debian/tmp/usr infodir=`pwd`/debian/tmp/usr/share/info mandir=`pwd`/debian/tmp/usr/share/man
+       dh_installdocs ChangeLog NEWS README
+       dh_installchangelogs
+       dh_installmenu
+       dh_movefiles -pginac-dev -pginac-doc
+       if test -f cint/ginaccint.bin; then dh_movefiles -pginaccint; fi
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_shlibdeps
+       dh_gencontrol
+       dh_makeshlibs
+       dh_installdeb
+       dh_md5sums
+       dh_builddeb -pginac -pginac-dev -pginac-doc
+       if test -f cint/ginaccint.bin; then dh_builddeb -pginaccint; fi
 
 binary: binary-indep binary-arch