]> www.ginac.de Git - ginac.git/blobdiff - debian/rules
input_parser accepts also pow() [A.Sheplyakov]
[ginac.git] / debian / rules
index e6493b5b2f3c869350829d17e51f0116222c7576..e15c5e6410a1328678103b3fbb4a36f53f725bf8 100755 (executable)
@@ -1,67 +1,17 @@
 #!/usr/bin/make -f
-# Made with the aid of debmake, by Christoph Lameter,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
 
-package=ginac
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
 
-version=$(shell expr `pwd` : '.*-\([0-9.]*\)')
-version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+       CXXFLAGS += -finline-limit=1200
+endif
 
-build:
-       dh_testdir
-       ./configure --prefix=/usr
+# 1.4.1-1-blah (Debian version) ==> 1.4 (LT_RELEASE)
+GINAC_RELEASE := $(shell echo $(DEB_VERSION) | cut -f 1,2 -d . )
+GINACLIB := libginac$(GINAC_RELEASE)
 
-       -mkdir shared static
-       #
-       # First build the shared library
-       #
-       cd shared ; \
-           $(MAKE) -f ../Makefile VPATH=".." srcdir=".." \
-               CFLAGS="-O2 -fPIC -pipe" ; \
-           gcc -shared -Wl,-soname,$(package).so.$(version_major) -o $(package).so.$(version) `ls *.o`
-       #
-       # Build the static library (it does not need Position Independent Code,
-       # which reserves one register; thus, without -fPIC we get more efficient
-       # code).
-       #
-       cd static ; \
-            $(MAKE) -f ../Makefile VPATH=".." srcdir=".." \
-                 CFLAGS="-O2 -pipe" LDFLAGS="-s" progs
-       touch build
-
-clean:
-       dh_testdir
-       dh_clean
-       -rm -f build
-       -$(MAKE) distclean
-       -rm -f `find . -name "*~"`
-       -rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
-       -rm -f debian/*substvars
-
-binary-indep: build
-       dh_testdir
-# There are no architecture-independent files to be uploaded
-# generated by this package.  If there were any they would be
-# made here.
-
-binary-arch: build
-       dh_testdir
-       -rm -rf debian/tmp `find debian/* -type d`
-       install -d debian/tmp
-       cd debian/tmp && install -d `cat ../dirs`
-       install -m644 static/$(package).a debian/tmp/usr/lib/
-       install -m644 static/gdbm.h dbm.h ndbm.h debian/tmp/usr/include/
-       install -m644 gdbm.3 debian/tmp/usr/share/man/man3/gdbm.3gdbm
-
-       install -m644 shared/$(package).so.$(version) debian/tmp/usr/lib
-
-       $(MAKE) install prefix=`pwd`/debian/tmp/usr
-       debstd -m ChangeLog NEWS README 
-       dpkg-gencontrol -pginac1-dev
-       chown -R root.root debian/tmp
-       chmod -R go=rX debian/tmp
-       dpkg --build debian/tmp ..
-
-binary: binary-indep binary-arch
-
-.PHONY: binary binary-arch binary-indep clean
+DEB_DH_MAKESHLIBS_ARGS := -V"$(GINACLIB) (>= $(GINAC_RELEASE).0)"
+DEB_DH_SHLIBDEPS_ARGS := --libpackage=$(GINACLIB) -l debian/$(GINACLIB)/usr/lib
+DEB_DBG_PACKAGE_ALL =
+DEB_DBG_PACKAGE_$(GINACLIB) = $(GINACLIB)-dbg