]> www.ginac.de Git - ginac.git/blobdiff - debian/rules
* Packaging update.
[ginac.git] / debian / rules
index 59570031d0a5510495a4ac2ade8d9a4c4df7a423..b3856a320e46f5be2978c6150e2a40bf54b5195c 100755 (executable)
@@ -1,6 +1,4 @@
 #!/usr/bin/make -f
 #!/usr/bin/make -f
-# Made with the aid of debmake, by Christoph Lameter,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
 
 package=ginac
 
 
 package=ginac
 
@@ -9,7 +7,7 @@ version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
 
 build:
        dh_testdir
 
 build:
        dh_testdir
-       ./configure --without-cint --prefix=/usr
+       ./configure --prefix=/usr
        $(MAKE) CXXFLAGS="-O2"
        touch build
 
        $(MAKE) CXXFLAGS="-O2"
        touch build
 
@@ -30,22 +28,25 @@ binary-arch: build
        dh_testdir
        dh_testroot
        dh_installdirs
        dh_testdir
        dh_testroot
        dh_installdirs
-       # When will Automake honor FHS?
+       # When is Automake going to honor FHS?
        $(MAKE) install prefix=`pwd`/debian/tmp/usr infodir=`pwd`/debian/tmp/usr/share/info mandir=`pwd`/debian/tmp/usr/share/man
        $(MAKE) install prefix=`pwd`/debian/tmp/usr infodir=`pwd`/debian/tmp/usr/share/info mandir=`pwd`/debian/tmp/usr/share/man
+       # Automake generated Makefile.in do install-info, which is bad for us:
+       -rm -f `pwd`/debian/tmp/usr/share/info/dir*
        dh_installdocs ChangeLog NEWS README
        dh_installchangelogs
        dh_installdocs ChangeLog NEWS README
        dh_installchangelogs
-       dh_installmenu -pginac-ginsh
-#      dh_movefiles -pginac-dev
+       dh_installmenu
+       mkdir -p `pwd`/debian/tmp/usr/X11R6/include/X11/pixmaps
+       cp `pwd`/debian/ginac.xpm `pwd`/debian/tmp/usr/X11R6/include/X11/pixmaps/
        dh_movefiles
        dh_strip
        dh_compress
        dh_fixperms
        dh_movefiles
        dh_strip
        dh_compress
        dh_fixperms
-       dh_shlibdeps
-       dh_gencontrol
        dh_makeshlibs
        dh_installdeb
        dh_makeshlibs
        dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
        dh_md5sums
        dh_md5sums
-       dh_builddeb -pginac -pginac-dev
+       dh_builddeb
 
 binary: binary-indep binary-arch
 
 
 binary: binary-indep binary-arch