]> www.ginac.de Git - ginac.git/blobdiff - debian/rules
behavior when expanding (x-x_0)^-n is more reasonable
[ginac.git] / debian / rules
index eec20aea89b1765d996a2172af55587a9dc8529b..90f269bd0623a22b1eb25f023615f02ec6576f80 100755 (executable)
@@ -1,6 +1,4 @@
 #!/usr/bin/make -f
-# Made with the aid of debmake, by Christoph Lameter,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
 
 package=ginac
 
@@ -9,7 +7,7 @@ version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
 
 build:
        dh_testdir
-       ./configure --without-cint --prefix=/usr
+       ./configure --prefix=/usr
        $(MAKE) CXXFLAGS="-O2"
        touch build
 
@@ -30,13 +28,14 @@ binary-arch: build
        dh_testdir
        dh_testroot
        dh_installdirs
-       # When will Automake honor FHS?
+       # When is Automake going to honor FHS?
        $(MAKE) install prefix=`pwd`/debian/tmp/usr infodir=`pwd`/debian/tmp/usr/share/info mandir=`pwd`/debian/tmp/usr/share/man
+       # Automake generated Makefile.in do install-info, which is bad for us:
+       -rm -f `pwd`/debian/tmp/usr/share/info/dir*
        dh_installdocs ChangeLog NEWS README
        dh_installchangelogs
        dh_installmenu
-       dh_movefiles -pginac-dev -pginac-doc
-       if test -f cint/ginaccint.bin; then dh_movefiles -pginaccint; fi
+       dh_movefiles
        dh_strip
        dh_compress
        dh_fixperms
@@ -45,8 +44,7 @@ binary-arch: build
        dh_makeshlibs
        dh_installdeb
        dh_md5sums
-       dh_builddeb -pginac -pginac-dev -pginac-doc
-       if test -f cint/ginaccint.bin; then dh_builddeb -pginaccint; fi
+       dh_builddeb
 
 binary: binary-indep binary-arch