]> www.ginac.de Git - ginac.git/blobdiff - debian/rules
Fixed some minor spelling errors.
[ginac.git] / debian / rules
index 33a1a431579c04e7a321d8079c9e07fda571e378..1bc08c6e2d4c410ec09d7f2ee9c23cbd79b980bc 100755 (executable)
@@ -1,19 +1,17 @@
 #!/usr/bin/make -f
 #!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/buildcore.mk
+
 include /usr/share/cdbs/1/class/autotools.mk
 include /usr/share/cdbs/1/rules/debhelper.mk
 
 ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
 include /usr/share/cdbs/1/class/autotools.mk
 include /usr/share/cdbs/1/rules/debhelper.mk
 
 ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CXXFLAGS += -finline-limit=1200
+CXXFLAGS += -finline-limit=1200
 endif
 
 endif
 
-# 1.4.1-1-blah (Debian version) ==> 1.4 (LT_RELEASE)
+# 1.5.1-1-blah (Debian version) ==> 1.5 (LT_RELEASE)
 GINAC_RELEASE := $(shell echo $(DEB_VERSION) | cut -f 1,2 -d . )
 GINACLIB := libginac$(GINAC_RELEASE)
 
 DEB_DH_MAKESHLIBS_ARGS := -V"$(GINACLIB) (>= $(GINAC_RELEASE).0)"
 DEB_DH_SHLIBDEPS_ARGS := --libpackage=$(GINACLIB) -l debian/$(GINACLIB)/usr/lib
 GINAC_RELEASE := $(shell echo $(DEB_VERSION) | cut -f 1,2 -d . )
 GINACLIB := libginac$(GINAC_RELEASE)
 
 DEB_DH_MAKESHLIBS_ARGS := -V"$(GINACLIB) (>= $(GINAC_RELEASE).0)"
 DEB_DH_SHLIBDEPS_ARGS := --libpackage=$(GINACLIB) -l debian/$(GINACLIB)/usr/lib
-DEB_DH_STRIP_ARGS := --dbg-package=$(GINACLIB)
-# menu entry for ginsh
-DEB_INSTALL_MENU_ginac-tools := debian/ginac-tools.menu
-
+DEB_DBG_PACKAGE_ALL =
+DEB_DBG_PACKAGE_$(GINACLIB) = $(GINACLIB)-dbg