* Fix incompatibilities with recent versions of libreadline by having
[ginac.git] / configure.in
index 692ba3eea868826af1d4b791825f9dfa70217ba1..efc2f8865e576e5b28d7d9f9944271fbce73d93a 100644 (file)
@@ -94,7 +94,9 @@ GINAC_TERMCAP
 save_LIBS=$LIBS
 LIBS="$LIBTERMCAP $LIBS"
 AC_CHECK_LIB(readline, readline)
-if test "x${ac_cv_lib_readline_readline}" != "xyes"; then
+if test "x${ac_cv_lib_readline_readline}" = "xyes"; then
+  GINAC_RLVERSION
+else
   GINAC_WARNING([I could not find libreadline (needed by ginsh).])
 fi
 GINSH_LIBS=$LIBS