]> www.ginac.de Git - ginac.git/blobdiff - cint/Makefile.am
- */Makefile.in: changes triggered by newer automake.
[ginac.git] / cint / Makefile.am
index 2884e6de82f0c0971377b22ef8269ab35bd05dab..c43b552320cff41bce343fde2955d1cbb4c4f812 100644 (file)
@@ -21,12 +21,16 @@ EXTRA_DIST = dummies.pl
 
 # Files which are generated by perl scripts
 $(srcdir)/dummies.h $(srcdir)/dummies.cpp: $(srcdir)/dummies.pl
-       cd $(srcdir) && perl dummies.pl
+       cd $(srcdir) && perl -w dummies.pl
 
 # Force build of headers before compilation
 $(srcdir)/ginaccint.bin.cpp: $(srcdir)/dummies.h
 
-# Force make clean to call Makecint's own Makefile
+# Force targets clean and distclean to call Makecint's own Makefile
 makecint_clean:
        (if [ -f Makefile.makecint ]; then $(MAKE) -f Makefile.makecint clean; fi)
+
 clean: makecint_clean
+       -rm -f libginac.*
+
+distclean: makecint_clean